need unbacked up files -- stuck in recovery mode loop -- i'm desperate :(

Discussion in 'Jailbreaks and iOS Hacks' started by LoopInfinitum, Aug 7, 2009.

  1. LoopInfinitum macrumors newbie

    Joined:
    Aug 7, 2009
    #1
    hey all,

    newly registered n00b here.
    my iphone froze, i hard reset, and it will only boot to the recovery mode screen.
    iTunes detects the device and says it needs to be restored.
    the problem is, i have precious data that isn't backed up (notes, pics, voice memos) -- i know, shame on me :( -- so i don't want to resort to a restore yet.
    i'm not sure which firmware i have, nor how to tell... it's a 16GB 3G (obvoiusly NOT jailbroken) and i believe i updated the f/w once early on...

    can you explore the file system or run fsck with programs like iRecovery or iBooter? i was able to get to the iBoot shell with iRecovery but I couldn't find the "get all your files back because you're an idiot that didn't back up" command. haven't tried iBooter.

    another plan was to quickPwn it (afaik this won't erase my data) and see where that takes me but versions 1.0 - 2.2.5 can't detect the device. nor can ZiPhone nor some PC program i tried (can't remember, i've wasted countless hours over a week already on this... not to mention it means i'm phoneless). but again, iTunes does...

    i'm desperate, please save me!!!

    thanks,
    john
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Lots of time if you have openSSH installed you can ssh into the phone if it is at the apple screen, and then you could backup the files that you need to.
     

Share This Page