Neither Camera Nor Card Reader Shows Up On My Desktop

Discussion in 'MacBook' started by aprylknight, Feb 17, 2011.

  1. aprylknight, Feb 17, 2011
    Last edited: Feb 17, 2011

    aprylknight macrumors newbie

    Joined:
    Feb 17, 2011
    #1
    I have a regular MacBook (OS 10.5.8) and a Casio EXILIM digital camera which uses an SD card. I've had this camera for a couple of months now, and have never had any problems plugging it directly into the USB port on my MacBook using the provided cable, and transferring the pictures to my computer. However, yesterday I tried plugging the camera into the USB port, and the icon didn't show up in the Finder. I waited a bit, checked to make sure both ends of the cable were securely plugged in, and waited a bit more. No icon. I unplugged the cable to try it in the other USB port (which also didn't produce an icon in the finder) and got the "Device Removal Error" message telling me I forgot to eject it before unplugging it. Both the light which comes on on my camera and the error message lead me to believe it is actually connected, but why is there no icon? I've also checked the System Profiler, and it doesn't show up there, either.

    I should also add that I've tried using the SD card in a USB SD card reader, and it doesn't load an icon on the computer, either (though I've never had any luck with this particular card reader). The USB port itself is ok, because I was able to plug my external hard drive in and have it load.
     
  2. Waragainstsleep macrumors regular

    Joined:
    Oct 15, 2003
    Location:
    UK
    #2
    Check that external disks are set to show up under the Finder preferences.
     

Share This Page