Neither MBP or MBA sleep with lid open

Discussion in 'MacBook Pro' started by puma1552, Mar 7, 2010.

  1. puma1552 macrumors 601

    Joined:
    Nov 20, 2008
    #1
    Neither my MBP 5,1 (Late '08) or MBA Rev. B will sleep with the lid open. The display will sleep, but not the computer. All energy settings preferences are of course set so as to have both the displays and machines sleep.

    I have nothing running except Safari--no third party downloading managers, no other apps, nothing. Bluetooth is off on both machines.

    I have reset both PRAM and SMC, as well as repaired permissions on the MBA, to no avail.

    "Use secure virtual memory" is checked in the security general preferences, as it should be by default. Just to test it I tried unchecking that, and it made no difference--computers will not sleep with the lid open.

    I even took the MBA out of my environment at home, taking it with me to the grocery store to see if it would sleep outside of this environment, and it still didn't, which to me rules out anything from Time Capsule causing it not to sleep--seems to definitely be something with the computers.

    This happens on both battery and AC power. I've now spent something like 2 hours playing with this and it's absolutely infuriating, since I can't call Apple for several more hours.

    I have printer sharing turned on on both computers, but that has never been an issue in the past, nor should it be. FWIW, the printer is powered down and unplugged in another room anyway.

    Closing the lid on both machines works, as does the keyboard shortcut to make the machines sleep.

    Ideas?

    Here is the console log from my MBP for today:

    And here is the one from my MBA...there is something going on with iStat here; I've always hated that program, but installed it to take the machine into the genius bar last week to have it looked at, and promptly uninstalled it when I got home. Nonetheless, there's something going on with it but even aside from that the machine won't sleep:

     
  2. puma1552 thread starter macrumors 601

    Joined:
    Nov 20, 2008
  3. puma1552 thread starter macrumors 601

    Joined:
    Nov 20, 2008
    #3
    Well, after 1.5 hours on the phone troubleshooting with Apple, the only option left is to reinstall the OS, a huge pain in the ass since I always do fresh installs and set my machines up as brand new machines rather than restore from backups.

    The PowerManagement.plist file was all messed up, with a hibernation value of 3 instead of 1 and a disk sleep value of 10 instead of 1...copied the file since it was read only and gave myself read and write access, changed the values by hand since SMC/PRAM resets weren't doing it, saved the info and still the computer won't sleep with the lid open, and now the only thing left is to reinstall the OS and if that doesn't work, then I have to take it in to the store.

    and sadly, my air has the exact same problem so im sure ive got my next four or five full nights planned out beautifully

    and im sure once im all done with that i may as well just zero out time capsule and start completely over again, even though i just did that a week ago when i got a fresh logic board in the pro.

    yay apple, more downtime than uptime
     
  4. wrongcoast macrumors newbie

    Joined:
    Oct 29, 2009
    Location:
    LA
    #4
    No sleep with lid open

    Puma 1552 -- Same problem here and I've seen many others posted on the Apple discussion pages with the identical situation. I'm with you, it's hard to believe nobody, not to mention any of the "top users" in the discussion groups, has come up with any answers for what I'm now convinced is an issue.
     
  5. Balooba macrumors member

    Joined:
    May 27, 2003
    #5
    Basic checklist

    Ok, you have reset pram and shut down all apps. Now, let's go over all the background processes that may force the system to stay awake. Set the system to sleep after 1 min of idling since you will test the sleep function after testing each step. If you do this properly and with patience you will find the cause for this issue.

    0. Double check that Safari isn't running,(I know you said you quit all apps but you have webkit issues in you log).
    1. You mention printer sharing, which is a listening process. Turn it off.
    2. In Energy Saver prefs, turn off Wake on Network
    Activity
    3. In Sharing prefs, turn off Screen Sharing, Remote Login, Remote Access, Internet Sharing and File Sharing
    4. Open Activity Monitor and see what third party processes you have running that may force the system to listen for activities. Quit them one by one. Thus absolutely includes your iStat deamon! You can contact Bjango later if it doesn't uninstall properly but for now just quit it in Activity Monitor.
    For example, do you have EyeTV Helper running? Do you have torrent type processes, Plex, Voddler or The Tube installed?
    5. Unplug every USB device.

    There is a myriad other things that can cause this, both software and hardware (I just found that my Kerberos process prevents sleep) but the steps above are the basics and you did no indicate that you had already checked those. Please post back what the results are.

    Good luck.
     

Share This Page