Nested Applications folders in iMac

Discussion in 'Mac Apps and Mac App Store' started by oliomedia, Feb 21, 2012.

  1. oliomedia macrumors newbie

    Joined:
    Feb 27, 2007
    #1
    I've found nested Applications folders on my new iMac running 10.6.8.
    There are three levels: Applications>Applications>Applications.

    NONE of these are aliases!

    The most deeply nested folder went to Trash (with all its contents), and emptied from Trash. The middle folder (one level down from the main Apps folder) will go to trash but will not empty from trash - neither will any of the items in it, not even one at a time. I get "The operation can’t be completed because an unexpected error occurred (error code -8003)."

    I've repaired permissions and verified the startup disk.

    Help please.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    You should only have one folder for apps, and that's the /Applications folder. What do you have in the /Applications/Applications folder?

    You can't empty the Trash or move a file to the Trash
    Solving Trash Problems
    Can't move files to trash
     
  3. jackrv macrumors 6502

    Joined:
    Jul 14, 2011
    #3
  4. oliomedia thread starter macrumors newbie

    Joined:
    Feb 27, 2007
    #4
    Problem solved

    Thanks for your replies.

    Just to answer your question

    - GGJ Studios: the Apps>Apps folder contained all the applications in the Apps folder - actual applications totalling 93GB. (The Apps>Apps>Apps folder contained most of the application files, but that trashed and emptied fine).

    - jackrv: I'd already tried force emptying to no avail.

    Before seeing any of your replies I persevered!

    I tried copying all the apps files in the trash to a new folder on a different hard drive. I then trashed that new folder, and it duly appeared in the trash, alongside all the existing apps files - again all the files were real files, not aliases.

    Emptying the trash then worked perfectly!!

    This nested Apps folder problem has occurred before a couple times since I bought my iMac last Summer. It's certainly not the result of anything I have done - the system seems to do it all on its own. This time is the first time I've had the emptying trash problem.

    Thanks again for your help. I've noted the links you recommended.
     
  5. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #5
    Well, it is most certainly due to something that someone has done to the computer. They don't do things on their own, yet. Now, that's not to say that the instruction given was correct, or that there is not a bug that caused it to do something other that Apple intended. But, it required input of some sort.
     

Share This Page