Nested RDC connections = shift keys broken

Discussion in 'Mac Apps and Mac App Store' started by agaskew, Dec 21, 2009.

  1. agaskew macrumors 6502

    Joined:
    Dec 3, 2009
    #1
    Quite often, I have to connect remotely in to work. To do this, I have to use a windows machine to connect to work. Once connected, the remote portal lets me run an RDC connection to my work desktop PC.

    So when doing this from the Air, I use the MS RDC client version 2 to first connect to my home windows server, then remotely connect to work, etc.

    Here's the problem - connecting to work is fine, but in the second (nested) RDC session, from my windows server to work desktop PC, the shift keys do nothing. This makes life tricky to say the least. Bizarrely, Caps Lock *does* work OK. I also think some other key mappings are stuffed.
    Double-bizarrely, the old MS RDC client works just fine in this regard, as do all other RDC clients I tried.

    Anyone come across this?
     
  2. DrewD67 macrumors newbie

    Joined:
    Feb 17, 2010
    Location:
    Peterborough, UK
    #2
    Did you ever solve this?

    I have a similar thing, connect from home on iMac or Air via VPN to windows machine in work somewhere then jump to my desktop windows machine in my office, and I get problems with the shift key, and sometimes takes a couple of tries to get Caps Lock on.

    I have held down the shift key and pressed the other key repeatedly and got an almost random switch between the 2 characters.
     
  3. Tom Kirby-Green macrumors newbie

    Joined:
    Sep 11, 2011
    #3
    I ran into the same problem and found that the following fixes it. Here's the setup I was using. I want to remote desktop from my MacBook Air into my old Windows 7 laptop, so that from there I can remote desktop into my workbox (a Windows 7 workstation). The last hop is over VPN, but that's not important.

    The trick is. On the Windows 7 laptop (i.e. the destination of the first hop), in the remote desktop connection details for the second hop, change the keyboard configuration to use the local keyboard. Works like a dream.
     
  4. DrewD67 macrumors newbie

    Joined:
    Feb 17, 2010
    Location:
    Peterborough, UK
    #4
    Someone at work recommended a program called CoRD, and this seems to work much better in these scenarios and has no problems with the key press.

    A free piece of software, but seems quite slick having used it a couple of times.
     

Share This Page