Net/router guru help needed (5Ghz network)

Discussion in 'Mac Basics and Help' started by Susurs, Dec 28, 2011.

  1. Susurs macrumors 6502

    Susurs

    Joined:
    Jun 18, 2010
    #1
    I purchased Netgear WNDR4500 router and wanted to set it up the way that my MacBook Air (2010/Snow Leopard with latest updates) connects to it via 5Ghz network only.
    The problem is that when I start up my Air one of the three times a message pops up on my MacBook saying "None of your prefered networks are available"
    but below the message it offers to connect to the other found networks and my 5Ghz connection is listed there. If I press it connection starts immediately. Sometimes it connects without a problem.
    If I add 2.4Ghz to known networks and MacBook can't connect to the 5Ghz (It's first prefered network in list)*it connects to 2.4Ghz. There are no such*problems with the other band.
    However I'd like have automatic connection to 5Ghz allways not manual.
    I tried different settings in router (security modes, no security, speed settings, network card access list, channels etc) but no luck...SSID's are CCC and CCC 5Ghz respectiveley.
    Maybe there are some advanced settings in router to solve this or terminal commands in MacBook.
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Try turning off the 2.4 GHz network on the router.
     
  3. Susurs thread starter macrumors 6502

    Susurs

    Joined:
    Jun 18, 2010
    #3
    For experiment I can try it but I have other devices that connects to 2.4Ghz ... IPhone for instance...
    I somehow think that it might be MacBook that can't recognise the network fast enough at startup (maybe).
     
  4. Susurs thread starter macrumors 6502

    Susurs

    Joined:
    Jun 18, 2010
    #4
    So I think I solved it (at least somehow)...

    I played with advanced airport preferences and set JoinModeFallback to KeepLooking instead of default DoNothing


    Command line:
    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport prefs joinmodefallback=keeplooking

    Now if at startup Air can't connect to my 5Ghz with first time it attempts a reconnect after some seconds and succeeds.

    Now only problem is that I need to find how to set interval between those reconnect attempts (if there is a way to control it) to like 5secs cause it's too long. (Reconnect always happens after like 20sec if not connected with first attempt).

    Any ideas?

    From the other side...if Air will be switched on where there are no networks and I decrease this interval - the battery life will suffer...
     
  5. Susurs thread starter macrumors 6502

    Susurs

    Joined:
    Jun 18, 2010
    #5
    By the way...Is it possible to create a script like: If SSID "CCC" detected than initiate a reconnect. ?
     
  6. psxguru macrumors 6502a

    Joined:
    May 19, 2006
    #6
    Do you use a different name for your 5GHz and 2.4GHz networks?

    I use different names and have the 5GHz listed first in my preferred networks. It always connects to the 5GHz network first for me.
     
  7. jekyl macrumors 6502

    jekyl

    Joined:
    Mar 6, 2011
    Location:
    Mid-Michigan
    #7
    That's how I handle things here.
     
  8. waynep macrumors 6502

    Joined:
    Dec 31, 2009
    #8
    Why does it matter what frequency it connects at?
     
  9. jekyl macrumors 6502

    jekyl

    Joined:
    Mar 6, 2011
    Location:
    Mid-Michigan
    #9
    There can be some really annoying interference with some cordless phones and most microwave ovens at 2.4ghz so moving things to 5ghz can help a lot. Also it might make things smoother if not all wireless devices are running over the same frequency.
     

Share This Page