Netflix App Fails to Play Content over WiFi

Discussion in 'iOS Apps' started by bendrucker, Aug 26, 2010.

  1. bendrucker macrumors newbie

    Joined:
    Mar 14, 2010
    #1
    Since I updated our two iPhones (3G and 4) and iPad to Netflix 1.1.0, when I try to play content over WiFi, the movie seems to be loading, but then the loading window closes and the app returns to the browsing interface. On the other hand, when I connect via 3G on my iPhone, it streams fine. I called Netflix to see if anyone else had reported the same thing, but no one had.

    Here's my setup:

    Comcast Cable > Linksys WRT160N > Device

    I haven't tested things on another WiFi network, but I suspect they would work. I'd been streaming via WiFi on my iPad for several months with no problems. It has to be something specific to my network. Has anyone experienced the same thing? If you have, please post some info about your network so we can try to identify where the issue is and help Netflix fix it in an update.
     
  2. samcraig macrumors P6

    Joined:
    Jun 22, 2009
    Location:
    USA
    #2
    I have no problems on my iPhone 4 and the netflix app on 3g or wifi in various locations
     
  3. Dorfdad macrumors 6502

    Joined:
    Oct 26, 2007
    #3
    Hmm same here using comcast and CISCO E3000 router wifi crashes after loading and back to app.
     
  4. ricco333 macrumors newbie

    Joined:
    Aug 26, 2010
    #4
    The same happened to me, it doesn't work at with my WiFi network but I went to the local McDonalds and I'm able to use it there with the free WiFi that they offer.
    I'm wondering what could it be, I have a wireless G Asus WL-520GU flashed with Tomato firmware and I haven't had any problems until now.

    Erik
     
  5. iHeartapple2 macrumors 6502

    iHeartapple2

    Joined:
    Jun 29, 2010
  6. EazyWeazy3 macrumors 6502

    Joined:
    Jul 13, 2008
  7. ytsejam1138 macrumors newbie

    Joined:
    Aug 26, 2010
    #7
    I'm having the same problem with Wifi as well. I have a Netgear WNR3500L router with the latest version of Tomato firmware. I'm running WPA2 with AES encryption for security. I disabled this, to see if it had anything to do with the problem and it didn't. I also drove up to a local free hotspot and Netflix loaded without any problems. I have UPnP enabled. I also tried it with NAT/PMP enabled still nothing. It starts to load the movie and then kicks me back to the selection screen.
    There has got to be some obscure setting in certain routers that's blocking Netflix over WiFi.
     
  8. 184550 Guest

    Joined:
    May 8, 2008
    #8
    No problems here. 3GS, 4.xx and a Netgear router.
     
  9. armv macrumors newbie

    Joined:
    Jun 22, 2010
    #9
    I'm having the same kind of problems! I'll click "Play", the video player comes up for a second, and then I'm kicked back to the queue.

    I'm using an ASUS WL-520GU with Tomato Firmware v1.28.9048. Could it be Tomato?
     
  10. ytsejam1138 macrumors newbie

    Joined:
    Aug 26, 2010
    #10
  11. armv macrumors newbie

    Joined:
    Jun 22, 2010
    #11
  12. sburgess73 macrumors newbie

    Joined:
    Sep 1, 2010
    #12
    Same Problem

    I have the same problem running a Netgear WNR 2000 V.2.
     
  13. eegerda macrumors newbie

    Joined:
    Sep 5, 2010
    #13
    Same problem

    I got the same problem with Buffalo wzr-hp-g300nh router running openwrt Backfire (r22689). Netflix works on my ipad with any other network..
     
  14. BuckoWA macrumors newbie

    Joined:
    Sep 11, 2010
    #14
    I was having this same issue on both the iPhone and iPad. To fix it, I set the DNS server on both devices to Google's DNS server at 8.8.8.8, which solved the issue. To do this, go to settings, Network and select your network. Edit DNS to 8.8.8.8.
     
  15. Bosnoval macrumors newbie

    Joined:
    Sep 12, 2010
    #15
    Netflix App Fails to Play Content over WiFi

    I'm having the same issues.

    Netflix app via wi-fi on iPhone 3Gs
    Netgear WNR3500L running DD-WRT v24-sp2 stdkong - build 15000

    That's an interesting fix. I'm not sure I'm willing to change my DNS information though. I guess I know it's a DNS issue at least, thanks!
     
  16. BuckoWA macrumors newbie

    Joined:
    Sep 11, 2010
    #16
    Netflix looks like a DNS rebind attack and DD-WRT is blocking it. If you find an alternate approach (other than reverting to earlier versions), please let us know!
     
  17. ytsejam1138 macrumors newbie

    Joined:
    Aug 26, 2010
    #17
    DD-WRT fixed the problem in r15050 by introducing the option to disable DNS-rebind protection in GUI (which you'll have to disable).
     
  18. BadaBing!! macrumors 6502

    BadaBing!!

    Joined:
    May 16, 2010
    #18
    Same problem here using Buffalo AirStation™ Nfiniti™ Wireless-N High Power Router & Access Point WZR-HP-G300NH w/ DD-WRT V24-SP2 build 14998.

    Easiest fix I found is to configure iPhone with a static IP address and DNS server (other than your router's IP) instead of DHCP.

    No update/downgrade to make... EASY fix. Hope it'll help others.
     
  19. tarhiny, Dec 2, 2010
    Last edited: Dec 2, 2010

    tarhiny macrumors newbie

    Joined:
    Dec 2, 2010
    #19
    As long as you do not need local DNS on your network, you can set your local DNS server on your router to a public DNS server (like Google's 8.8.8.8) and still be able to use DHCP on your clients. NOTE: You'll need to release/renew your DHCP clients after you make this change (or disconnect from/reconnect to the WIFI network).

    ** edit ** If you're running dd-wrt, you'll also need to DISABLE the following:

    Use DNSMasq for DHCP
    Use DNSMasq for DNS
     
  20. potluckdesign macrumors newbie

    Joined:
    Jul 10, 2009
    #20
    Netflix fails on Apple-TV with Buffalo Router WZR-HP-G300NH

    Same thing happens with the loading screen and kick back to start screen for me and our Buffalo AirStation™ Nfiniti™ Wireless-N High Power Router & Access Point WZR-HP-G300NH w/ DD-WRT V24-SP2 build 14998. Problem is when I change the DHCP to DNS 8.8.8.8 I loose the HD quality but does play Netflix movies. Any other fixes for routers? Any chance this is a port issue?
    Any info appreciated.
     
  21. BadaBing!! macrumors 6502

    BadaBing!!

    Joined:
    May 16, 2010
    #21
    I have the exact same router and I dont loose HD when using Google DNS .
    Try opendns DNS : 208.67.222.222..

    (And I just dont see why a DNS change would change the quality of a stream..)
     
  22. bendrucker thread starter macrumors newbie

    Joined:
    Mar 14, 2010
    #22
    There was some speculation with the Apple TV that using OpenDNS or Google DNS could increase loading times (based on some user's experimentation). Apple uses Akamai to handle some of its streaming and people suspected that Akamai was determining users' approximate locations based on their DNS servers in order to route them to the nearest streaming server. OpenDNS and other 3rd party DNS services were preventing this from happening. It's unconfirmed, but it seems plausible.
     
  23. Wakkorotti macrumors newbie

    Joined:
    Jan 13, 2011
    #23
    tarhiny, I could kiss you

    Thanks to all for their input. I'm running DD-WRT v24-sp2 (08/07/10) std on a Linksys WRT400N. My WiFi streaming of Netflix on both my iPhone4 and iPad had stopped working at some point over the holidays. After following the advice from tarhiny to disable DNSMasq for DHCP and DNS, it's now working back to normal.

    Ahhhh, sweet streaming oblivion, once again... :eek:
     

Share This Page