Netflix ATV-ui31 problem with 'Children 12 and under' profile

Discussion in 'Apple TV and Home Theater' started by spd, Oct 2, 2015.

  1. spd macrumors newbie

    Joined:
    Nov 19, 2008
    #1
    Hi,

    I use my Apple TV to stream Netflix almost daily, and in my normal day to day profile it works without a problem.

    Today, I wanted to use the Kids profile but I couldn't connect. The message I receive is 'We're unable to connect you to Netflix. Please try again later (ATV-ui31).

    I tried creating a new profile, and setting it to 'Children 12 and under'. When I tried to connect - got exactly the same message above. If I edited the profile to 'Teen' it works fine. Changing it back to '12 and under' and the problem re-occurs. Editing it back to teen or adult and the problem goes away. It's definitely re-creatable.

    If I search for kids content in my normal profile it will stream fine, so it's the '12 and under' setting that's the problem.

    There are no restrictions set on my ATV.

    Anyone help?

    TIA,

    SPD
     
  2. StevenWalker macrumors regular

    Joined:
    Oct 19, 2014
    #2
    What did Netflix support say when you chatted with them??
     
  3. StevenWalker macrumors regular

    Joined:
    Oct 19, 2014
  4. spd thread starter macrumors newbie

    Joined:
    Nov 19, 2008
    #4
    No such symbol in the profile name. It is simply called 'Kids' (without the quotes). It's fairly standard isn't it?

    They told me to power cycle the ATV, leaving it off for a minute or so, then sign out and sign back in.

    I also fully reset the ATV.

    This is how the chat ended.

    "Netflix Don
    Gotcha!, thanks for that, I am adding your Apple TV to the report so we can still working on it, in the meantime you can use any other device as this is affecting just Apple TVs, please try later in your Apple TV for a resolution.

    You
    I am hoping that you can resolve it as it is frustrating. I can search for children's content in my adult profile and it will stream fine. The problem is only affecting my Apple TV, specifically with 12 and under profiles.

    Netflix Don
    Oh I wish I could be on the engineers department to get that solved for our customers and of course get paid more lol, but no worries although here in customer service have no the tools to get that done, our Team is aware of it and currently working on it.

    You
    Ok, I will wait and see if a resolution is found.

    Netflix Don
    Alright thanks, I am glad I could help with this info! Hope you have a great evening!! and thanks again for your report oh! And one more thing, if you wouldn’t mind, please stay online for a one question survey."

    SPD.
     
  5. StevenWalker macrumors regular

    Joined:
    Oct 19, 2014
    #5
    Check to make sure there is not any sub account associated with your subscription with a "&" in it.

    If there is, delete it - then log out of netflix on your atv.... then log back into netflix again after your sure no account has an "&" in it.
     
  6. spd thread starter macrumors newbie

    Joined:
    Nov 19, 2008
    #6
    No, only got two profiles, mine which is my first name and then the Kids one.

    Mine streams fine.
     
  7. StevenWalker macrumors regular

    Joined:
    Oct 19, 2014
    #7
    Just to test the theory, because it only takes 2 mins to do.

    Go to PC... netflix... ensure there is only one sub account showing... then rename both Profiles... Parent...Child.
    Log out, and back in... make sure that it worked.

    Now go over to your ATV... log out of netflix.....power OFF ATV.... 10secs...repower ON....sign in to Netflix....should now be working.
     
  8. spd thread starter macrumors newbie

    Joined:
    Nov 19, 2008
    #8
    Tried that - sadly no joy.

    Thanks for trying to help though.

    SPD.
     
  9. Dino F, Oct 11, 2015
    Last edited: Oct 11, 2015

    Dino F macrumors 68020

    Dino F

    Joined:
    Sep 16, 2010
    Location:
    Croydon, South London, UK
    #9

    I had the same exact issue on my ATV. My Kids profile was set to "12 and under" and for the past week or so, was also getting the ui-31 error. My main adult profile worked fine though.

    As soon soon as I switched the Kids profile to "teens", the ui-31 error disappeared?!! Guess I'll need to leave it set to "Teens" now! Wonder what's actually causing this issue?!

    Also, just to add, this issue is only present on Apple TV as I also have Netflix on my Virgin Media TiVo and also Xbox One and neither of these experiences this issue!
     
  10. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
    #10
    Hard reboot the Apple TV by unplugging the power cord. wait a few minutes then reconnect it.
     

Share This Page