Netflix DVD halfway stuck in the drive

Discussion in 'iMac' started by acidity, Feb 5, 2008.

  1. acidity macrumors regular

    Joined:
    Sep 7, 2006
    #1
    Hello

    So I received my DVD yesterday. Didnt check for any scratches etc before putting it inside.

    Now my DVD is halfway inside and I just cant eject it.

    It does not come on Finder.
    I have tried pressing EJECT button for no avail.
    I tried CMD OPT P R and CMD OPT O F to start in firmware more but it seems that they only work for PowerPC versions.
    Last but not least I tried pressing the mouse button while the OS is booting up.

    All of the above and no sign of anything. It dosnt many any sound. If I try to insert another DVD, it goes inside like less then quarter of an inch and I can feel the old DVD up there.

    Is taking it to Apple Shop the only way?
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Condition described is not "halfway stuck in the drive". Seems like it's fully in the computer but it's unreadable. In that case,

    Reboot, hold down main mouse button until disk is ejected.
     
  3. devilot Moderator emeritus

    devilot

    Joined:
    May 1, 2005
    #3
    Shrug. Looks like the OP already tried that.

    I dunno, mebbe some of you are more techy or adventurous. Mebbe some of you aren't lucky enough to live close to an Apple store. But if I've got a hardware issue, I pretty much just head to a Genius Bar. Don't wanna mess around too much lest I break something or void a warranty. :eek:

    Hope it gets fixed, acidity.

    FTR, I'm always paranoid about using public library DVDs (I'm pretty sure Netflix ones aren't like these) but they have all that barcode paper/ tape stuck on the surface that makes the DVDs uneven (thicker and thinner in places) and often means they can get stuck easily in slot drives. :(
     
  4. themoonisdown09 macrumors 601

    themoonisdown09

    Joined:
    Nov 19, 2007
    Location:
    Georgia, USA
    #4
    You can call Apple and find out where the nearest Apple Authorized Service Provider (AASP) is if you don't have an Apple Store nearby.
     
  5. acidity thread starter macrumors regular

    Joined:
    Sep 7, 2006
    #5
    Tried the mouse press option. Though I did it with a Logitech 2 button mouse. I have an Apple Mouse somewhere. I will check with that tonight when I get back home from school.
     
  6. acidity thread starter macrumors regular

    Joined:
    Sep 7, 2006
    #6
    well, ideally if a CD is completely inside, when you push another CD/DVD it should go further and see that a DVD is already inside on the slot.

    In my case, i can feel the stuck DVD as soon as I enter a new one. It should have gone further and settled down on the slot if it had been correct.
     
  7. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #7
    Doh!

    Left mouse button on a 2 button mouse. Should make a noise.

    Perhaps someone pushed 2 disks in it. I've heard stories from my Mac Genius friends...
     
  8. acidity thread starter macrumors regular

    Joined:
    Sep 7, 2006
    #8
    Nothing.

    Now that might be a possibility. Maybe I was thinking something else and put the DVD inside.....anyway to check that out? Though, that *someone* can be nobody other then *me*........
     
  9. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #9
    Try reboot while holding option. This will come to a start up disk selection. Typically dvds not recognized as startup disk are ejected.

    Apple products comes with 1 year applecare.

    Contact their number or make appointment with a local apple store's genius bar:
    apple.com/retail
     

Share This Page