Netflix + HDCP error

Discussion in 'OS X Yosemite (10.10)' started by nightrider89, Oct 17, 2014.

  1. nightrider89, Oct 17, 2014
    Last edited: Oct 17, 2014

    nightrider89 macrumors newbie

    Joined:
    Nov 19, 2013
    #1
    So I eagerly updated to Yosemite when the version was released on the apple store. First impressions are good up until I plan to watch some netflix.

    I usually do a lot of multitasking so I use a matrox dualhead2go to get my main monitor on my laptop and two monitors above. However, when I start netflix with the externals connected, I get a "Display error...Make sure monitors are HDCP compliant and not Airplay Mirroring." I saw some members getting this error when Yosemite was in beta but no one has responded with a solution.

    However, I would like to add that this set up worked perfectly on Mavericks using the external monitor. Any update on the issue from any members? Is this something I should report to apple? Do you think this will be fixed in an update or is this something embedded into Yosemite forever?


    Hopefully theres an answer out there that can revert the settings so it worked when it was on Mavericks.

    Also worst case scenario, would I just need to revert back to Mavericks?

    EDIT: forgot to mention, I have a 2012 cMBP 13"
     
  2. The Phazer macrumors 68030

    Joined:
    Oct 31, 2007
    Location:
    London, UK
    #2
    What are the two monitors?

    Are they HDCP complaint?

    How are they connected?
     
  3. nightrider89, Oct 17, 2014
    Last edited: Oct 17, 2014

    nightrider89 thread starter macrumors newbie

    Joined:
    Nov 19, 2013
    #3
    one monitor is a Dell S2240lc. I looked up the specs for this and did not find if it was hdcp compliant. (it wasnt listed on the dell website but I am assuming no) Also this monitor is connected via hdmi (not sure if that matters)

    other monitor is a Dell P2212Hb. This is HDCP compliant.

    They are connected through the Matrox DualHead2Go DP edition which basically uses a thunderbolt and usb (power) to converge the two monitors into one big monitor.

    I guess I find it odd that it worked flawlessly on Mavericks but not on Yosemite. Didn't even need drivers

    Thanks for the quick reply
     
  4. lun macrumors newbie

    Joined:
    Sep 6, 2014
    #4
    Did you try to restart to make it work again? Or does it never work?

    I do not know why, but I get this error as well sometimes. I have one dell hooked up via dvi.
    A restart fixes this behavior.

    I sometimes even get: "What do you need to stream..." and have to restart the browser a couple of times.

    But it's been a couple of weeks since Netflix arrived here, so I never tried it with Mavericks.
     
  5. d5280 macrumors newbie

    Joined:
    Feb 13, 2008
    #5
    I experienced the same issue. What I discovered was that I was triggering it because I was using screen sharing to control the mac mini I had attached to the TV. I believe it is because the new screen sharing might be using a air play protocol and is thus triggering an HDCP error.
     
  6. nightrider89, Oct 17, 2014
    Last edited: Oct 17, 2014

    nightrider89 thread starter macrumors newbie

    Joined:
    Nov 19, 2013
    #6
    Tried restarting twice! The first time didnt work so I attempted to use HTML5 (deleted silverlight) and the restart still gives me the same problem.

    Guess like I'll be contacting Apple in someway.

    Ugh this is blows... I mean its not so much a deal breaker because it is only effecting netflix but it is annoying.

    Edit: Update. When I run both monitors off the Matrox, I get a Netflix error. When I run netflix on an individual monitor, I dont get an error and runs fine. So I am assuming Yosemite is not getting along with the Matrox unit

    Also I spoke with an apple tech and we are trying to resolve the issue with Yosemite. Seems like a lot of others are getting this issue. It also leaves me with a couple of options. All opinions are welcomed:

    1) I can wait for Yosemite to try to fix this issue. I am sure if enough people are reporting it, that they will change something in the OS giving us an update

    2) I can revert back to Mavericks and run my monitors without issues

    3) I can use one monitor, sell the matrox unit and keep yosemite

    4) any others?

    2nd EDIT!: I found a work around, use a different browser. I currently use firefox to run netflix and works well. So it looks like the problem is from safari
     
  7. rob5280 macrumors newbie

    Joined:
    Oct 17, 2014
    #7
    HDCP error problem with Netflix and Yosemite

    I just uploaded the new Yosemite last night and tried to watch Nexflix. I got an errowabout a display problem, HDCP compliant and airplay? I'm reading that others have this issue. That suck! Anyone figured out how to fix this?
     
  8. nightrider89 thread starter macrumors newbie

    Joined:
    Nov 19, 2013
    #8
    So after speaking to a tech, he wasnt really able to figure out why safari was not letting me watch netflix. However, we did manage to find a work around. I think this error has something to do with safari.

    I was asked to use another browser so I tested with firefox (v31.0) and I was able to watch netflix without the error. Not the most ideal situation but at least its working for now.

    Hope this helps others that are having netflix errors as well.
     
  9. rob5280 macrumors newbie

    Joined:
    Oct 17, 2014
    #9
    Thank you so much that did work and I tried Chrome and it worked also so your right it is a Safari issue. Like you said not perfect but till Apple fixes it I'll at least be able to watch on these browsers.
     
  10. ideal.dreams macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    Ohio
    #10
    Just searched Google for this same issue - glad there are others having the problem and it's not just me. Using an AOC 24" 2436Vw monitor which is definitely HDCP compliant. Looks like I'll be using my iPad until it's fixed.

    I noticed some different behavior when using YouTube with Safari on Yosemite too, maybe it's all connected.
     
  11. missen33 macrumors newbie

    Joined:
    Oct 19, 2014
    #11
    Temporary fix to this problem

    Ok Guys,
    I have been expeirienceing the same problems and so after quite a lot of communication with both Applecare and Netflix I have found out what the problem is and how to temporerily watch Netflix.
    Netflix have'nt properly updated and made there site run in safari in OS X Yosemite, but if you download Google Chrome it works!!
    Took me ages to find this out!! Anyways Apple are now aware of the problem and I am sure it will be fixed ASAP. Till then you will just have to watch Netflix in Chrome. Amazon instant Video and Youtube work fine in Safari...
     
  12. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #12
    Having this issue/error when trying to use AirPlay. The error message is annoying because it makes it sound like you should know better "Error because you don't have a compatible monitor or are using AirPlay". Like there is something wrong with using AirPlay and you shouldn't be attempting it in the first place.

    The issue is from Safari defaulting to HTML5 vs using Silverlight like it did in Mavericks.

    So the options are, if you want to use Safari goto your Netflix account, playback preferences and turn off HTML5. This will revert to Silverlight and will AirPlay fine*in Safari.

    If you want to use HTML5, just leave the setting for HTML5 on in Netflix and use Chrome, Firefox, etc.

    You can't currently have both Safari and HTML5 Netflix when using AirPlay. You'd think Safari would be a little bit more powerful with Apples stances on browser extensions.

    Please bring this to Apples and Netflix attention so hopefully its addressed.
     
  13. killr_b macrumors 6502a

    killr_b

    Joined:
    Oct 21, 2005
    Location:
    Suckerfornia
    #13
    From what I can tell, you can only use the Netflix html5 player in Safari and with an HDCP compliant monitor that is either internally connected or over a connection that is up-to-date with the latest HDCP compliance.

    So if you are using Chrome or Firefox, you have the Silverlight plug-in installed. (If you got Chrome and Firefox working but not Safari 8, it's because Silverlight is already installed and Safari is attempting to use the html5 player and not the Silverlight plug-in) If you don't have Silverlight installed, Firefox and Chrome will prompt you to install it.

    If you want to use a non-HDCP monitor (such as the aluminum Apple Cinema displays) you have to use the Silverlight plug-in.

    I just haven't made it work any other ways.

    Post your experiences here.
     
  14. jacksonic macrumors newbie

    Joined:
    Oct 22, 2014
    #14
    safari and no netflix with yosemite

    I have the same problem with netflix and safari. So far the only solution is to use Chrome and add the plugin it requests. Silverlight is no longer used with Safari. Security embedded in Safari is the culprit. Personally I think it recognizes any software such as Supertube HD, AirVideo, Aimersoft, et al., which are used to transfer or convert video as they enhance by attaching to the Safari browser and blocks the attempt to attach. You used to be able to simple "reset" Safari to clear the preferences, but if you notice, there is no reset under the "file" menu. Apple could and should bring back the "reset" button. Till then use Chrome and search for the fix.
     
  15. jev425 macrumors 6502

    jev425

    Joined:
    Sep 12, 2014
    Location:
    Seattle, WA
    #15
    I have two monitors hooked up to my mac mini and I get the same error. What I noticed is that if my second monitor ha power turned off I get the error but if I turn it on it works fine
     
  16. NoJamSteele macrumors newbie

    Joined:
    Nov 9, 2014
    Location:
    Arizona
    #16
    Problem Solved

    Simply login to Netflix, go to "Your Account", and scroll about halfway down the page to "Playback Settings" where you can turn off the HTML5 over Silverlight preference and you're good to go!!
     
  17. morgan1112 macrumors newbie

    Joined:
    Nov 18, 2014
    #17
    Problem is NOT solved - The work around has been removed by Netflix

    This fix is no longer available because Netflix has removed it from the Playback Settings. I called Netflix tonight to complain about it and they were no help. I have three dual monitor Mac Minis that are displaying this HDCP compliance error. All of the monitors are HDCP compliant. However, HDCP does not work if you are using VGA cables or using AirPlay via Apple TV. Apple and Netflix are shooting themselves in the foot with this new streaming setup. I'm choosing to use VGA cables for good reasons. 1. I don't want to buy another $30 dongle for this mac mini that converts Thunderbolt to HDMI. I already have a perfectly good VGA dongle that works fine with the exception of Netflix\Safari\Yosemite 2. On the other dual monitor Mac Mini, I'm intentionally not using HDMI cables because VGA cables offer more resolution options for the LCD displays. My wife needs the ICONS and letters to be larger and the resolution options are not available for this with HDMI cables. The only way I have ever gotten her preferred resolution on this Mac mini is with VGA cables which do not permit HDCP communication with the monitor. 3. I am using an Apple TV on one of my dual monitor living room configurations using a Mac Mini. If I connect the HDMI cable extended through the wall to the 2nd LCD TV it complains about HDCP compliance. If I use a shorter HDMI cable not run through the wall, it works fine. I usually use Apple TV with Airplay on this Mac Mini and Netflix\Safari\Yosemite does not work due to HDCP errors. I've got three Yosemite, Mac Mini, dual monitor Netflix hell issues here!!!! Netflix is killing me by removing the Playback setting work around. Apple is killing me with the enforcement of HTML 5 DRM. I'm so sick of this DRM crap. Quit messing with this video technology!!!!! Just stream the friggen video and stop jacking with the technology. By the way, Chrome works fine with Netflix on all these computers. Apple and Netflix need to backpedal here and support VGA cables, Support Apple TV and test all this crap a little better next time......

    NO LONGER WORKS......

    "Your Account", and scroll about halfway down the page to "Playback Settings" where you can turn off the HTML5 over Silverlight preference and you're good to go!!"
     
  18. donaciano macrumors newbie

    Joined:
    Oct 31, 2013
    #18
    Solved!

    This fixed it for me. :D I have this problem on an iMac with an external display using DisplayPort. Unplugging it doesn't let Netflix work, but deleting AirParrot did the trick.

    It looks like someone used a quick and dirty method to detect screen grabbing software that could be used to record Netflix movies. Instead of allowing Netflix while they're not running, it simply blocks all HDCP playback if the software is even installed.

    I don't see any mention of Netflix on the AirParrot site so it looks like we may be some of the first to figure this out. Please let me know if the fix works for you too.
     
  19. ManicMoov macrumors newbie

    Joined:
    Jan 15, 2015
    #19
    I have been sitting back for the last couple of months waiting for either Netflix or Apple to sort this out, but the forums seem to have gone quiet and still no solution is forthcoming.

    Has everyone just stopped using Safari?

    Just to add my findings to the long list above, I get the "Please ensure your monitor is HDCP compliant" message when using the latest Safari (8.0.2) on any of my Mac setups:
    iMac - with just a built in display.
    Mini - with an Apple thunderbolt display and thunderbolt cable.
    Mini - with VGA cable.

    All used to work under Mavericks.
    All used to work in Yosemite, disabling HTML5 in Netflix (until that became no longer an option).
    All work in Chrome now.

    I'd love to think that Apple (or Netflix) are busy behind the scenes working on the problem, but the fact that a new Safari patch came out last week, leads me to think this is not the case.

    It's worrying also that the forums have gone so quite on the issue. Have I missed something obvious?
     
  20. Sabretooth78 macrumors member

    Sabretooth78

    Joined:
    Nov 13, 2012
    Location:
    Western NY
    #20
    A way around this that I found works for me (so far, YMMV) is to enable the "Develop" menu in Safari and from that menu, change your User Agent to a prior version of Safari.

    I agree, it's a ridiculous limitation. I use a MacMini as a HTPC and as such it is most convenient to control it using screen sharing. This seems like the same "feature" that broke the ability to remotely control DVD playback in Mountain Lion. At least a superior solution to that was to just encode the DVDs using Handbrake.
     
  21. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #21

    Can you think of any cons to doing this? Just curious.
     
  22. ideal.dreams macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    Ohio
    #22
    There aren't any cons to doing this. Safari only sets the user agent for that one tab so none of your other tabs are affected. It's also reset when you close the tab, so if you were to open Netflix in a new tab it would be using the default user agent.

    It appears that all this workaround does is stop HTML5 playback and force Silverlight playback. Alternatively you can disable HTML5 playback in your Netflix settings and avoid having to change your user agent each time you want to use Netflix on your computer.

    I found this workaround about a week ago and I've been using it. It's an extra step required to binge watch but it works.
     
  23. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #23

    Netflix got rid of the html5 playback option. So it defaults to html5. That is why I find this option (which works) interesting.

    I guess I need to set the user agent to an older version of safari THEN go to playback settings and see if the HTML5 option is there. It's not there in safari 8.

    Who should I be emailing about this Netflix or Apple? Seems Netflix to me.
     
  24. ideal.dreams macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    Ohio
    #24
    Probably Apple since the issue only started happening after upgrading to 10.10
     
  25. jms969 macrumors 6502

    Joined:
    Feb 17, 2010
    #25
    Make sure silverlight is completely removed from you system... Took care of the problem for me...
     

Share This Page