Netflix / MS Silverlight DRM

Discussion in 'Mac Apps and Mac App Store' started by xury, Jan 1, 2009.

  1. xury macrumors newbie

    Nov 28, 2008
    I am having problems with Microsoft Silverlight on my Intel 2.0 macbook.

    Apparentely, it is not recognizing DRM. I have tested the application at a silverlight DRM test site and did not get a response from the testing device telling me it was working properly.

    I am primarily attempting to watch movies instantly on Netflix. Nexflix recognizes that the software has been installed correctly (going to confirms my 'successful installation'), and the netflix application will even load and buffer the movies. The application sticks on the 'setting up your movie player' screen.

    I called Netflix, and they said 'call microsoft'. I don't think they have a clue.

    I have noticed a problem viewing episodes of programs on and they apparently use silverlight as well. There is another 'flash' type program that won't run properly as well on my browser. (fyi - I am using safari, but have tried firefox as well).

    Can someone point me in the right direction on how I might remedy this issue?

    Thanks in advance,

  2. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    I'm not sure whether the Mac version of Silverlight supports DRM or not. I just tried to install it on my machine but the installer fell over and told me that it doesn't run on PowerPC (my system is Intel). Go Microsoft! :p
  3. xury thread starter macrumors newbie

    Nov 28, 2008
    According to Netflix, it should be working - they specifically support Intel Macs. I have seen some other users post different questions about Netflix streaming problems using Intel Macs (they were able to stream, however with choppy issues, etc.), which adds to my confusion further.

    The error message I received on Netflix, and on the Silverlight DRM test was:

    "Individualization Failed".

    Again, thanks for the help. Any further solutions or direction would be greatly appreciated.
  4. NeoMayhem macrumors 6502a

    Aug 22, 2003
    Uninstall the silverlight plugin, reset safari and then install silverlight again. Make sure you have the newest versions of both.
  5. wildthing macrumors newbie

    Feb 14, 2009
    Can't stream DRM-Protected Netflix Movies

    I an havng the same problem trying to play Netflix movies on my iMAC Intel 10.4.

    I get this message: "Individualization failed. Unable to playback unprotected (DRM) content. Error Code: 8152."

    I have re-installed the Silverlight plugin 3 times and tried playing the movie in both Firefox and Safari browsers after clearing the cache, turning off firewalls, etc., all to no avail.

    Neither Netflix or Microsoft couldn't advise me. If anyone has had this experience and fixed it, let me know and thanks.:eek:

Share This Page