Netflix not loading on ATV2 running 4.2.2

Discussion in 'Apple TV and Home Theater' started by important, Apr 21, 2013.

  1. important macrumors member

    Joined:
    Jul 13, 2009
    #1
    Anyone else having this issue? I am on firmware 4.2.2 on my AppleTV2 and when I select Netflix from the main menu, I immediately get a screen that says "Netflix is currently unavailable. Try again later." No menu, nothing but that screen. I've tried power cycling the Apple TV, but to no avail. This just started about 3 or 4 days ago, and nothing on the Apple TV setup has changed.

    I'm wondering if suddenly Netflix is incompatible with older firmware versions or something, so I'm curious to see if anyone else is experiencing this. If you have an ATV2 on 4.2.2, I'd appreciate knowing if you can access Netflix or not. Thanks.
     
  2. MFL2012 macrumors member

    Joined:
    Jul 27, 2012
    #2
    First thing to try is to turn off home sharing on your ATV and then turn it right back on. This should have nothing to do with Netflix, but has worked for me in the past. It takes 10 seconds, try it.
     
  3. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #3
    try rebooting your router and modem.

    also if your aTV is using wired ethernet, try switching to wireless, there have been some odd behaviors in the past.
     
  4. important thread starter macrumors member

    Joined:
    Jul 13, 2009
    #4
    Thanks - I just tried that, but it didn't have any effect.


    Tried rebooting my modem and router, too. Switched from wireless to ethernet, too. Still having the Netflix issue.

    Any other thoughts? Is anyone else on 4.2.2 having this issue? Thanks in advance.
     
  5. MFL2012 macrumors member

    Joined:
    Jul 27, 2012
    #5
    With a few updates to Netflix recently, you may be SOL. Any particular reason you won't update your ATV? I have an ATV2 and it runs perfectly with the latest firmware.
     
  6. important thread starter macrumors member

    Joined:
    Jul 13, 2009
    #6
    Mine is jailbroken at 4.2.2, and the latest ATV2 firmware only allows for a tethered jailbreak. I might end up having to bite the bullet and update and do the tethered.
     
  7. MFL2012 macrumors member

    Joined:
    Jul 27, 2012
    #7
    Have you tried signing out of Netflix and signing back in? Doubt it would work, but may be worth a try as a last resort.
     
  8. important thread starter macrumors member

    Joined:
    Jul 13, 2009
    #8
    I couldn't even get to the main Netflix menu to sign out - but thanks for the suggestions.

    I decided to upgrade and rejailbreak. The upgrade to 5.2.1 fixed the Netflix issue, now I just need to jb it...
     
  9. closer9 macrumors newbie

    Joined:
    Apr 25, 2013
    #9
    Same issue here with 4.2.2. Started around the same time as you.

    Let me know how the upgrade and jailbreak work out. I tried to upgrade to 4.4.4 and had nothing but issues due to Apple not signing for those older releases anymore.

    I'm also interested to see how well Plex works for 5.2.1 since it's not supported on that release yet.
     
  10. important thread starter macrumors member

    Joined:
    Jul 13, 2009
    #10
    The upgrade and JB worked fine. Everything is running properly now - Netflix, XBMC (which even seems faster, running Frodo 12.1 on the ATV2 with 5.2.1). I don't run Plex (XBMC negates my need for Plex).

    Just be aware that 5.2.1 is a tethered JB only right now, so if for some reason you have to restart your ATV (lose power, unplug it, etc.), you'll have to boot up via a tether.
     
  11. slammers macrumors newbie

    Joined:
    Sep 28, 2008
    #11
    I have the exact problem. Can you explain how you upgraded you 4.2.2 to 5.2.1? Did you just do an upgrade through apple and then re-jailbreak. Or did you do an upgrade through your PC connecting the ATV to a USB port?

    I want to get Netflix working but can not risk losing my XBMC functionality as that is much more important.
     

Share This Page