Netflix on Apple TV not in the US n various issues

Discussion in 'Apple TV and Home Theater' started by jdaniel, Oct 29, 2013.

  1. jdaniel macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #1
    So not being in the US you need a DNS service or full VPN to get Netflix, netflix works fine on my mac but I am having issues getting it to work on my atv.

    I get as far as the login page then it fails and seems to detect that I am not in the US. Anyone using unotelly DNS service or something similar?

    It's very weird because I enter the DNS directly into the atv, and it is also on my mac whose internet connection I am sharing with the atv via Ethernet cable
    Thanks!!
     
  2. Stewart21 macrumors regular

    Joined:
    Dec 9, 2011
    Location:
    South Yorkshire
    #2
    Isn't there a setting that identifies the country you are in? Maybe you need to change that as well.
     
  3. jdaniel thread starter macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
  4. institute macrumors regular

    Joined:
    Oct 10, 2012
    #4
    With Unotelly you can have, say, a Canadian Netflix account, login to that account as Canadian. Once logged in go to the Unotelly web site Dynamo page where you can select what country you want for Netflix. Select US Netflix, reenter the Netflix app and you should get the US version.
     
  5. jdaniel thread starter macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #5
    Yes I have no issues with the mac I just doesn't seem to be fooling them on the atv , I am in a country with no netflix so even visiting the page would not be possible if it didn't work on my mac. Apparently the atv sees thru this Dns trickery
     
  6. institute macrumors regular

    Joined:
    Oct 10, 2012
    #6
    It shouldn't if you have the right DNS manually setup in the Network settings of the ATV. Are you using Plexconnect with this?
     
  7. jdaniel thread starter macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #7
    That's the thing with plex connect what I did was connect the atv via Ethernet to my Tb display Ethernet port and set the atv DNS to the ip of my mac and use internet sharing. There's more complications with that if I restart the mac it seems I have to disable internet sharing, first then restart after I start plex connect via terminal wish there was a simpler way.

    So If my atv is sharing my connection and my connection has the dns already set should that not be enough? I access netflix on my mac no issues.

    BUT it doesn't seem to work so I did apply the unodns on the atv directly just for testing it seems to allow me to sign in page instead of telling me the location is not supported, but then it stops me from going further and again it tells me not supported location. So even if I forgo plexconnect it doesn't work....

    So how can I do this with plex connect too? My dns on the mac whose internet is being shared directly with the atv is already set to unotelly, I am out of ideas sigh
     
  8. institute macrumors regular

    Joined:
    Oct 10, 2012
    #8
    In the Plexconnect Settings.cfg file set the ip_dnsmaster to the unotelly ip. Leave everything else as normal. Plexconnect will then forward all calls from the ATV through the unotelly ip. And of course make sure the ATV is set to the ip of the computer running Plexconect.
     
  9. jdaniel thread starter macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #9
    omg you totally fixed it !! THANKS ! now that I know you are good with these things can you help me with the rest of it?

    my plex on the atv is not showing any of the art work, all I am seeing is grey boxes.. and this is a new thing that presented itself today.. I have restarted that pos numerous times, I have looked at the plex server manager on my mac to look at the agent settings...i cant see anything that might be an issue...do you know what might be the problem?
     
  10. institute macrumors regular

    Joined:
    Oct 10, 2012
    #10
    I responded to your thread in the Plexconnect forum on the Plex web site. Best to keep the troubleshooting discussion there.
     
  11. jdaniel thread starter macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #11
    done thanks :)
     

Share This Page