Netflix performance/responsiveness on Apple TV or Roku

Discussion in 'Apple TV and Home Theater' started by TitanTiger, Sep 29, 2012.

  1. TitanTiger macrumors 6502

    Joined:
    Jun 8, 2009
    #1
    I currently use Netflix on my TiVo Premiere but the performance is lacking. Takes too long to register a response to fast forwarding and rewinding. A lot of blinking (screen goes black for a second). I was thinking a dedicated box like a Roku or Apple TV might be better.

    Those who stream Netflix and have used one or both, how was it in terms of how snappy the menus were and how quickly commands to pause, rewind or fast forward were during movies? I hate trying to FF but then hitting the play button and nothing happening for 3-5 seconds while it zooms past where you wanted to go.
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    I have the Apple TV 2 & 3, and they work great, no slowness or flickering. They respond quickly and as long as you have a fast Internet connection, you should get next to no buffering.
     
  3. OllyW, Sep 29, 2012
    Last edited: Sep 29, 2012

    OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #3
    Same here.

    There's usually a delay of a few seconds before the video starts playing and I've been using it for 9 months and have only had a couple of instances when the picture has paused for buffering.
     
  4. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #4
    I've had that happen a couple of times over the last year or so, but it was attributed to my Internet connection having issues.
     
  5. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #5
    It was probably the same here. :)
     
  6. TitanTiger thread starter macrumors 6502

    Joined:
    Jun 8, 2009
    #6
    Yeah, I'm fine with it taking a few seconds to buffer before it starts. It's just the ridiculous delay when trying to rewind or fast forward that drives me crazy. Sometimes there are scenes that we don't want to watch with kids in the room or whatever, or we want to rewind to hear some dialogue again and it's nearly impossible to use with the Tivo because of this lag issue.

    I have a 25Mbps internet connection so I should be good there.
     

Share This Page