Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

bigrids

macrumors newbie
Original poster
Nov 27, 2017
26
8
I've not been able to watch anything on Netflix recently on my Apple TV. The app loads but when you select a programme to watch I just get a spinning wheel. Anyone else had similar problems. I can watch it through my smart tv no problem.
 

-Gonzo-

macrumors 6502a
Nov 14, 2015
737
339
I don’t suppose you’re in the UK and your ISP is Virgin Media.
Netflix are aware of issues with Apple devices but they’re currently seeing the majority of reports coming from Virgin Media customers.
 
Comment

bigrids

macrumors newbie
Original poster
Nov 27, 2017
26
8
I don’t suppose you’re in the UK and your ISP is Virgin Media.
Netflix are aware of issues with Apple devices but they’re currently seeing the majority of reports coming from Virgin Media customers.
Spot on. UK and Virgin Media. Just tried rebooting and signing in and out but it still won't play anything.
 
Comment

cynics

macrumors G4
Jan 8, 2012
11,630
1,909
If it makes you guys feel any better I can't get anything to play from across the pond on Comcast. It was working fine, switch to a different episode of the show I was watching and nothing. Spinning wheel for days.
 
  • Like
Reactions: bigrids and -Gonzo-
Comment

-Gonzo-

macrumors 6502a
Nov 14, 2015
737
339
If it makes you guys feel any better I can't get anything to play from across the pond on Comcast. It was working fine, switch to a different episode of the show I was watching and nothing. Spinning wheel for days.

Have you reported it to Netflix?
 
Comment

bigrids

macrumors newbie
Original poster
Nov 27, 2017
26
8
I've just had an on line chat with Netflix and after restarting my Apple TV and deleting and reinstalling the Netflix app still nothing is loading. They say they are aware of the problems and are working on it. Watch this space I guess.
 
  • Like
Reactions: -Gonzo-
Comment

-Gonzo-

macrumors 6502a
Nov 14, 2015
737
339
Everything seems to be working again
Well videos are playing at least, navigation is still a bit sluggish though.
 
Last edited:
Comment

fjpgt3

macrumors newbie
Nov 7, 2010
5
0
FYI: I was having the same issue with Amazon Prime Video only, Netflix etc all worked normally. I tried reinstalling etc, nothing.
I talked to Apple support and recommended trying a new HDMI cable,... that fixed it. What a surprise! Those cables can slightly degrade over time.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.