Netflix Streaming

Discussion in 'Mac OS X Lion (10.7)' started by NameUndecided, May 10, 2011.

  1. NameUndecided macrumors 6502a

    Mar 28, 2011
    For all of the versions of the developer preview, Netflix streaming has given me a DRM error message. At first, I thought that this might be an issue with Silverlight within an at-the-moment incompatible OS, but then I found out that not everyone is suffering from this.

    It's been okay for the most part, rebooting back into Snow Leopard if I'd like to watch a movie on my MBPro, but now I'm becoming more and more tired about it.

    The error message is a simple "DRM Error" notification that the Netflix viewer gives, with error code: N8151, and to try closing and re-opening the browser or calling their customer support.

    I've tried both Safari and Firefox (the two compatible browsers, according to Netflix), and I've tried uninstalling and re-installing Silverlight, installing both onto, or either onto, the Snow Leopard partition and the Lion partition of my hard drive.

    Could anyone offer some insight or suggestions, or to say if Netflix is or isn't working for you? Particularly if you're using Lion on a partitioned disc, as I am.

    Thanks very much if anyone has any ideas!
  2. mrapplegate, May 11, 2011
    Last edited: May 11, 2011

    mrapplegate macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    Works with both Safari and Firefox for me. Works on a non-partitioned system and a partitioned system on mine.
    Silverlight version 4.0.51204.0
  3. Blipp macrumors 6502

    Mar 14, 2011
    EDIT: Retracting my statement, didn't realize I was answering this in the 10.7 forum. This is what happens when you have too many macrumors tabs open at one time.

Share This Page