Netflix Watch Now on Parallels

Discussion in 'Windows, Linux & Others on the Mac' started by Tadow, May 11, 2007.

  1. Tadow macrumors member

    Joined:
    Oct 3, 2006
    #1
    Has anyone had any success using the Watch Now feature on Netflix while using Parallels? The movies were very choppy/unwatchable when I tried last night even with 1GB of ram dedicated to Parallels.
     
  2. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #2
    1GB RAM might be too much. Remember, OS X is hosting Parallels which is running Windows. Any RAM you assign to the guest OS will not be available for the host OS, and everything starts to slow down.

    It's a mistake many newcomers to virtualization make, thinking that the more RAM they add to the guest, the faster it will be. Just last week, I watched a colleague at work struggling with a slowly responding Linux VM. I checked his settings and he'd pushed the guest RAM up to 1.5GB. I got him to reduce it to 512MB and it was much better. There seems to be a sweet spot at about 1/4-1/3 the host's RAM.

    Anyway, I haven't tried Netflix Watch Now in Parallels, but I have in VMWare's Fusion, with 512MB. It was fine.
     
  3. Tadow thread starter macrumors member

    Joined:
    Oct 3, 2006
    #3
    I have 3GB ram so that would be in the 1/3 ratio but I will try it again with 512, thanks.
     
  4. himansk macrumors regular

    Joined:
    Oct 16, 2006
    #4
    watch now on netflix was fine for me with 700MB dedicated from 2GB total.
     
  5. Tadow thread starter macrumors member

    Joined:
    Oct 3, 2006
    #5

    Are you using Vista or XP in parallels?
     
  6. gbshuler macrumors newbie

    Joined:
    May 12, 2007
    #6
    Doesn't work for me either

    Brand new Macbook Pro 17 with 2GB. Windows XP SP2 in Parallels with 512MB. Picture is choppy (starts and stops). Completely unwatchable. Any ideas? Should I try 768MB? I tried shutting off many services (using Startup and Control Panel manage computer -- isn't there another Windoze utility to shut down services?).

    If I run in Bootcamp will that help? I really want to use Netflix Watch Now now!

    Thanks
     
  7. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #7
    bootcamp is native so it definitely should work in bootcamp
     
  8. VoodooDaddy macrumors 65816

    Joined:
    May 14, 2003
    #8
    I just tried this in parallels-vista with no success. My video was choppy also, and at one point it stopped and said "adjusting movie based on connection speed, will begin in 3hrs 18min" and started buffering it!

    I noticed while the movie was trying to play my connection was jumping erratically. It would go up to 500-600kbps, then drop down to 8-10kbps. However, when I run the "test connection" on the site it pegs at 1.2mbps.

    Guess I wont be using that feature. And I doubt theyll be rolling it out to OSX anytime soon. :rolleyes:
     
  9. jdechko macrumors 68040

    Joined:
    Jul 1, 2004
    #9
    Right-click on "My Computer", select "Manage", Click on the "Services and Applications" then on "Services".

    You can do a quick Google search for which services you can disable safely.

    Quick link of first result

    Additionally, you can temporarily kill some of the services by using the task manager, but it's a little less descriptive of what the service is.
     
  10. joeconvert macrumors 6502

    Joined:
    Nov 18, 2003
    Location:
    TX
    #10
    I think you are better off just wating for the 3D accelerated version of Parallels to ship. I suspect no matter how many services you turn off, this is going to be a no go in the current release.
     
  11. VoodooDaddy macrumors 65816

    Joined:
    May 14, 2003
    #11
    Thing is, Ive read other reveiws on the watch now service from ppl using it in parallels and their only complaint was lack of movie selection. So as it is now, it should work in parallels.
     

Share This Page