Netgear WGR614 v6 router problems... slow internet

Discussion in 'Mac Accessories' started by danileson99, Feb 6, 2009.

  1. danileson99 macrumors newbie

    Feb 6, 2009
    I've narrowed it down to that as the problem, as my gf's PC which is half as powerful as my mac, if that, is faster than my macbook online!!. And everywhere else I go I have fast internet on it. I have tried doing the DNS thing and that hasn't done anything... As you can probably tell I'm pretty useless at this kind of thing. But my internet speed is way over 6/7 meg, which should be quick right?? and it takes a long time just browsing internet. Someone told me it could be incompatibilty between the macbook and the router?? PLease help my painful internet. :confused:
  2. wakerider017 macrumors 68000


    Sep 20, 2006
    US of A
    I would say to flash the router with DD-WRT but they do not have support for that version of your router yet.

    Are you connected via ethernet or wireless?

    If you have 7megabit download speed you should be seeing downloads in the range of 875 kilobytes per second. (This can fluctuate depending on the source you are downloading from.)

    Try a speed test here:

    You may also want to try a different browser than the one you are using.

    If I had to guess the problem likely lies with your Macbook, but if you would like to get a new router I can recommend some very good ones for a cheap price.
  3. plinden macrumors 68040


    Apr 8, 2004
    You say you have fast internet wherever else you go, so I'd say it's a problem with the interaction between the router and your MB.

    Open /Applications/Utilities/Network Utility and ping your router. If you see dropped packets, that's the problem.

    I had an earlier version of the WGR614 that played well with a PC and my Mac Mini, but dropped connections to my wife's MacBook while keeping them at full speed when it was connected, and maintained connections to my iMac but throttled the speed to 1/4 that of the other computers.

    I solved my problems by replacing it with an AEBS.
  4. danileson99 thread starter macrumors newbie

    Feb 6, 2009
    Hey thanks for all your help. I think I have fixed it by setting the router to DNS aswel as the MB, is that what you're supposed to do?? well it has sped everything right up to proper speed now.
    I pinged and got this:

    Ping has started ...

    PING ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=54 time=25.551 ms
    64 bytes from icmp_seq=1 ttl=54 time=23.854 ms
    64 bytes from icmp_seq=2 ttl=54 time=24.844 ms
    64 bytes from icmp_seq=3 ttl=54 time=37.180 ms
    64 bytes from icmp_seq=4 ttl=54 time=26.749 ms
    64 bytes from icmp_seq=5 ttl=54 time=41.437 ms
    64 bytes from icmp_seq=6 ttl=54 time=25.810 ms
    64 bytes from icmp_seq=7 ttl=54 time=34.573 ms
    64 bytes from icmp_seq=8 ttl=54 time=24.574 ms
    64 bytes from icmp_seq=9 ttl=54 time=23.771 ms

    --- ping statistics ---
    10 packets transmitted, 10 packets received, 0% packet loss
    round-trip min/avg/max/stddev = 23.771/28.834/41.437/6.084 ms

    which means absolutley nothing to me, but everything seems to be running fine now. Thanks again.
  5. velocityg4 macrumors 601


    Dec 19, 2004
    I have that same exact model and revision number of the router you have. Have you updated to the latest firmware? Until reading this thread I just realized that I had not yet done so and noticed a quicker response from my internet connection. Be sure to follow the instructions in regards to resetting the router to factory default after performing the firmware upgrade or it will not take effect.

    Also change the wireless channel used by your router to diffuse interference from other sources. I have also found connections with any router to be more reliable if you assign Static IP addresses to each of the computers on your network.

    If you do not know how to access your routers web app it should be accessible by going to through any web browser unless you changed the routers address. The default username is Admin and the default password is password.

    After Router Reset
    1. Connect via Ethernet cable
    2. Launch any Web browser which will automatically direct you to the routers setup wizard. It will do most settings automatically at this time. I would suggest at this time to give your network a unique name, and set up Wireless security (WPA-PSK prefereably).
    Note: Changing your routers default web access password does not work in this wizard though so do not bother at this point.
    3. After the Wizard is finished connect your Wireless computers to the Network name you created and supply the encryption key you chose when your computer asks for it.

    Changing your wireless channel

    Static IP
    You can give each computer an IP address that they will have every time they connect to your network. I have found this improves connection stability especially with local file sharing an network attached devices like printers.
    1. Log in to your routers Web access
    2. Click on "LAN IP Setup" in the left column
    3. Under "Address Reservation" click "Add"
    4. You will now see a list of all devices currently connected to your LAN
    5. Click the radial button of one of the devices the "MAC Address", "IP Address", and "Device Name" should fill out automatically. You may change the IP Address if you want at this time
    6. Click "Add"
    7. repeat steps 3 to 6 for each device (the list of devices to add will shrink so one device does not get two IP addresses)
    8. Click "Apply" when you are returned to "LAN IP Setup" and wait for your router to reset.

    Product Manual

    Hopefully this helps with your connection speed and stability.

Share This Page