Network clients user icons not visible- Maverick Server

Discussion in 'Mac OS X Server, Xserve, and Networking' started by aham1, May 23, 2014.

  1. aham1 macrumors newbie

    Joined:
    May 22, 2014
    #1
    Have a small OSX network consisting of a Mac Mini server (Mid 2010 4GB RAM 2-500 GB HD) and 20 27 inch iMac client workstations used by around 350 user accounts. All were originally running Snow Leopard for over 2 years and did fine.

    Decided to do an in-place upgrade to Maverick on Server and workstations a few months ago. Immediately had an issue with the network users icons not displaying correctly on the client workstations. I would see the first 25 icons fine but the rest were not visible. I know they were there as the left/right arrow buttons would let you scroll to the end and back but the icons past the initial 25 were not visible. If you were to pause in the area of blank icons and wait 15 minutes or so the icons would appear on the screen, but it was only "their group of 25 or so". If you then scroll past these the icons to the left or right the other (including the first 25) were still not visible!! Also need to mention that logon was incredibly slow...like 3 minutes or more.

    After a couple of weeks the problem went away. I assumed a patch had resolved the issue or things just "settled down". Worked fine since.

    Began to experience other issues and decided to do a fresh install of Maverick 10.9.3 on the mac mini server this week. The icon visibility issue has returned!!! What could be the problem?:mad:

    I think DNS is fine as it checks out correctly and worked fine with Snow Leopard. I use profile manager on Maverick and it works and responds to the client workstation promptly and correctly. All clients and server are on a single 24 port Cisco switch. Internet bandwidth is ok but not extreme. I have bound (and unbound and rebound) the clients to Open Directory and this seems to work as they resolve the DNS name correctly.

    Any ideas on what could cause the network user icons to not display correctly on the clients? Or would cause the logon (both network or local account) to be so incredibly slow?? I am out of places to look.
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    I don't bother with user icons in my environment so I can't address that. Your setup is slow because you have a computer that's too slow with not nearly enough RAM for the task at hand. User logon is very disk and network intensive and the 2 500GB disks that came in a 2010 Mini server are slow. Is your network gigabit ethernet? If not, you should at least get the connection from your server to the switch upgraded.
     
  3. aham1 thread starter macrumors newbie

    Joined:
    May 22, 2014
    #3
    I do understand the mac mini is not a power server, but even with only a single client attempting access the results are the same. Seems to me there has got to be some configuration or setup that is causing the issue.
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    In that case, start with the basics. Use Activity Monitor to check on RAM and CPU usage first, and check system logs for errors. I still suggest that 4GB of RAM is too low for this system.
     
  5. aham1 thread starter macrumors newbie

    Joined:
    May 22, 2014
    #5
    Installed 8 GB RAM in mac mini server and reinstalled OSX from scratch. Installed Snow Leopard Server and immediate upgrade to Maverick before adding any user accounts or configuring server services.

    Took one of the iMacs and installed fresh copy of Maverick.

    Started loading network accounts in Open Directory and all works great, until I get to the 26th network account and then the "icon issue" appears as before. Must be some sort of issue with Maverick, but I can't solve. Also cannot find any reference to a known bug from anyone else.

    Does anyone use the Network User icon on the client to help users login? We are a school for mentally challenged and some don't spell very well. Having their picture on the icon sure does help!!!
     
  6. aham1 thread starter macrumors newbie

    Joined:
    May 22, 2014
    #6
    Stumbled on a solution (very simple)!!!

    Selecting the visible left/right arrows on the client using the mouse causes the problem. If you scroll using the left/right keys on the keyboard all is well!!!

    Dang simple but took way too long for me to discover;)
     

Share This Page