Network configeration problem please help

Discussion in 'Mac Basics and Help' started by Nuthatch, Dec 20, 2011.

  1. Nuthatch macrumors newbie

    Joined:
    Dec 18, 2011
    #1
    Hi
    My Mac has decided to have a network configeration problem that I can't resolve.

    Here is what I do know. I'm an amateur.
    Macbook 1.1
    Intel Core Duo
    OS X 10.6.8

    • Wireless working fine on my Mac and then I went to a different part of the house, out of range and it disconnected.
    • Tried to reconnect and to no avail.
    • Wireless definitely working (using old PC which is connecting - doesn't have mictrophone for skype)
    • On advice - went into TCP/IP and renewed DHCP license - didn't work
    • Tried with manul IP address got from this PC info. the airport says it is now connected but still no internet connection.
    • Have turned things off and on router, disconnected this PC from wireless just in case limited licenses - no use

    Am now stuck. Hope someone can save us, as would be Very sad not to speak to family on Christmas day as we are house sitting in Spain in the middle of nowhere (up a mountain so not hot and sunny but still very beautiful) with no landline or mobiles and so skype is my only 'phone home' on Christmas day option.

    This is my first post and comes with lots of thanks for previous help when I've had a problem with my macbook (five years old) and always searched MacRumours forums.

    If anyone can help I'd be grateful, as would Mum, Dad, Auntie.... :)

    Thank you and Happy Christmas to you and your families.

    Caroline
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    First, just to be sure, have you rebooted the MacBook? If not, do. That fixes about 80% of problems. Also, while you're at it, open Disk Utility and do "Repair Permissions" on your hard drive if you haven't recently; highly unlikely that will make any difference, but it won't hurt to do it just to rule out the 0.1% chance that was part of the problem.


    Assuming you already done those things, try the following, which is basically to delete all current network settings and start fresh:

    Open Keychain Access in your Utilities folder, and do a search for anything related to the network that's not working. Delete any entries you find.

    Open the Network Preference Pane, select AirPort (or whatever the wireless option at left is called), Click the Advanced button at lower right, then go through the list of Preferred Networks and delete everything there. While you're in there, turn DHCP back on, and on the same tab set Configure IPv6 to Off (I've had IPv6 mess things up with certain routers or ISPs).

    Click OK, then "Apply" (if it's not grayed out).

    Now let's be extra-extra paranoid, though I have no idea whether this will help; in the Network pref pane make sure AirPort is selected at left, and click the "minus" button at the bottom of that pane to remove it from the list. Click "Apply". Now click the "plus" down by the minus; select Airport from the popup that appears, and click OK; that should re-add AirPort. Click Apply.

    Finally, go back to the Advanced settings for Airport, and confirm that DHCP is on and IPv6 is off; if not, fix them.

    Now reboot, for the extra voodoo. Try connecting and see if you have any luck.
     
  3. Nuthatch thread starter macrumors newbie

    Joined:
    Dec 18, 2011
    #3
    Still network problem but thanks for the reply

    Hi
    Thanks very much for writing to me with some instructions. I really appreciate getting a reply.

    Duly followed, but have made no difference. Going down to the local bar with wi fi this afternoon to see if I have any luck.

    Thanks again. Any further suggestions welcome.
     
  4. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #4
    Too bad that didn't help. The results at a different wifi network will help diagnose.

    If it works fine down there, it's either some sort of very weird preference problem, or it's actually the router screwing up somehow (MAC address filtering, for example, though the symptoms of that are different).

    If it doesn't work there either, it's either the whole wireless subsystem that got hosed somehow, or the wifi card actually broke (which is rare, but possible).

    The best diagnostic in either case, unfortunately, is to get your hands on an external hard drive and do a clean installation of the OS so you can boot from that and test, completely ruling out the software on the computer. If you don't have an external (which you should for backups, at minimum, but if it doesn't have the free space), or you want to try something a little trickier and have the free space available, you can repartition your internal drive on the fly and install on the other partition.

    If it comes to that you can ask for instructions here or find them online in a number of places.
     

Share This Page