Network Connection Idle Time Out

Discussion in 'macOS' started by SPCW!, Jan 18, 2016.

  1. SPCW! macrumors newbie

    Joined:
    May 23, 2014
    #1
    Hi, A 2012 iMac is connected to a corp domain via ethernet cable. Screen sharing is configured and has been in use for remote connections from outside the building for ~3 years. In recent months, an issue has arisen where the network connection on the iMac is either lost or automatically powered down after some amount of idle time. When the user logs in at the iMac in the morning, the network is initially not connected, but immediately connects after login.

    This behavior is new as of the past few months, and effectively makes screen sharing for remote connections useless, as the iMac is not connected and available for screen sharing sessions.

    I suspect this came about from an update which may have made changes to the way Energy Saver settings handle the network connection. Perhaps the update from Yosemite to El Capitan, or perhaps another update around that time.

    How does one enable the network connection to remain on and connected full time?

    Thanks!
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    In the Energy Saver Prefs uncheck the top to checkboxes and check the bottom two. See attached screenshot Screen Shot 2016-01-18 at 11.32.33 AM.jpg Screen Shot 2016-01-18 at 11.32.33 AM.jpg
     
  3. SPCW! thread starter macrumors newbie

    Joined:
    May 23, 2014
    #3
    Thanks, I'm going to check the current settings and set as suggested. I'll check it in the morning and let you know the results.
     
  4. SPCW!, Jan 18, 2016
    Last edited: Jan 20, 2016

    SPCW! thread starter macrumors newbie

    Joined:
    May 23, 2014
    #4
    This iMac is running El Capitan currently, and it does not show the top option in your screenshot, “Prevent Computer from sleeping when the display is off”. That is the very one I thought might resolve the issue. Why would this iMac not have that option?

    ETA: Reading elsewhere it seems that the energy saver options vary with the model and version. The core issue remains: The network connection, and perhaps the whole system, appears to be sleeping. How can it be set to stay awake full time?

    ETA: We checked the schedule under Energy Saver, and it was set to sleep after 20 minutes. We set sleep to Never, and I expect this may well resolve the problem.

    I'm not sure if it was set this way before upgrading to El Capitan, or if the upgrade changed the setting. I do know the Screen Share problem started after the upgrade, so it appears the upgrade brought about some change with the Sleep settings.

    ETA: Turning off Sleep fixed it. I just didn't think to look at the Sleep settings because Sleep had never been enabled. Thanks for the help.
     

Share This Page