'network connection refused'

Discussion in 'macOS' started by ajmccoll, Jan 2, 2009.

  1. ajmccoll macrumors newbie

    Joined:
    Feb 19, 2008
    #1
    I have looked everywhere to find an answer to this problem, and so far nothing has helped.

    I am currently on my aluminum iMac trying to connect to the iTunes store, software update, or check the weather from the dashboard, and nothing loads. When trying to connection to the iTunes store or software update I get the error message that the 'network connection was refused' and to check my internet connection.

    I am connected to the internet, I can browse the web, obviously post this problem, and get on AIM, everything works fine except for things that I need to connect to through apple. I have tried reinstalling mac os, unplugging the router and wireless, flushdns (like one unhelpful apple article suggested) but still it doesn't work.

    I can connect to and do everything I can't do here on my macbook, so it's my imac that is the problem - nothing else.

    Does anyone have an answer on how to fix this, or anything they suggest I try to do? Thanks in advanced.
     
  2. goldfronts macrumors member

    Joined:
    Dec 23, 2008
    #2
    i wonder if it has something to do with your firewall settings on the imac? if not - try repairing the disk permissions and see if that helps out at all
     
  3. ajmccoll thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #3
    thanks for responding. while i have made no changes to the firewall settings on my imac since this problem began, i am currently repairing permissions to try and see if that helps. i'll let you know how it goes.

    edit: nope. repairing permissions fixed nothing.
     
  4. Ashka macrumors 6502a

    Ashka

    Joined:
    Aug 9, 2008
    Location:
    New Zealand
    #4
    Setup a new admin account and try that. If it works you at least know the problem is only in your account not the OS.
    If it's OK you could consider moving everything over to the new account.
     
  5. ajmccoll thread starter macrumors newbie

    Joined:
    Feb 19, 2008
  6. ajmccoll thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #6
    fixed!

    For anyone experiencing this same problem, I was able to fix it by completely wiping my hard drive and reinstalling mac os. I didn't transfer any of my old settings to the new configuration so I guess I did something to mess it up. Thanks to everyone that tried to help me out, I really appreciate it.
     
  7. goldfronts macrumors member

    Joined:
    Dec 23, 2008
    #7
    Ah that'll do it! Glad you got it working again :)
     

Share This Page