Network drive... headache

Discussion in 'macOS' started by coolmatt, Jun 15, 2015.

  1. coolmatt macrumors newbie

    Joined:
    Oct 6, 2012
    #1
    Hi,

    I connect to a Ubuntu server from my Mac but this machine appears twice in Finder under "Shared" : one time with its name (cronos) and another time with IP... Clicking on the IP address works and I can access the content but if I click on the name... connection fails :-(
    The wierd thing is : I can SSH the server with "cronos.local" !

    Does anybody know how to fix this situation : remove one of the links from the finder and keep the name instead of the IP ?

    Maybe a hint : a while ago I switched from AFP to SMB... if this rings a bell ?


    Thank you for your help.
    Regards,
    matt.

    [​IMG]

    NB : "MEDIA" is another mount (USB disk)
     
  2. coolmatt thread starter macrumors newbie

    Joined:
    Oct 6, 2012
    #2
    Here is the solution :

    On Ubuntu :

    1/ Disable avahi-daemon
    2/ Modify /etc/samba/smb.conf file by adding (after the WORKGROUP lin) :

    netbios name = NAME (where NAME defines your server name)

    3/ Restart Samba : sudo service smbd restart

    On Mac :

    Login again...
     

Share This Page