Network failed after system restore

Discussion in 'OS X Mountain Lion (10.8)' started by Jynto, Jun 6, 2013.

  1. Jynto macrumors 6502


    Jan 16, 2012
    Nottingham, UK
    I had some compatibility problems with 10.8.4, so I just restored 10.8.3 from a bootable backup on an external hard disk (via Carbon Copy Cloner, in case that matters). Since then, I have not been able to connect to my home W-fi network. I just get an error message saying 'Could not join "network name". A connection timeout occurred.'

    I tried restarting my Macbook Pro. I tried restarting the router. And that didn't help. I tried booting again from the external disk, and somehow it is able to access the network just fine. I restored again from that backup, and still I get the same problem.

    My Mac is able to connect to other networks. They all have passwords, but they don't give the same error, which appears before I even get the chance to type in a password. Other devices can access the same network, including my Nexus 7, which I am using to post this.

    I searched for this error message, and it sometimes seems to be caused by two machines on the same network having the same MAC address. Something is causing the router to 'remember' my backup drive as the computer it wants to connect to, and reject my Mac as a duplicate of that machine.

    Any ideas besides throwing my router out the window?


    Aaargh!! No sooner than I post this problem on the forums, the damn thing decides to fix itself! I don't know what I did, except unplug a hard disk and a USB hub.


Share This Page