Network hangs on large downloads with Mavericks

Discussion in 'OS X Mavericks (10.9)' started by headfuzz, Dec 28, 2013.

  1. headfuzz macrumors 6502

    headfuzz

    Joined:
    Apr 13, 2007
    Location:
    Brighton, UK
    #1
    Hi all, apologies if this has been posted before, I searched for "Mavericks network hang" and didn't get anything suitable back.

    I have an Early 2013 13" rMBP that I upgraded to 10.9.1 yesterday from 10.8.5.

    After checking that Ableton Live Suite and all my plugins worked ok, I thought everything had gone smoothly.

    Until I tried to download the remaining audio packs.

    It seems a larger download ( > 500 MB ) will get so far then suddenly hang. I've tried this with Firefox and Safari and both Ableton Live audio packs and Linux ISO images; all manifest the same behaviour: get so far then suddenly stop, so it's not a particular file or site.

    Once the browser has hit this point there is no more browsing to be done. It just sits there saying connecting to <insert name of arbitrary site here> with a spinning loading wheel (FF) or slowly progressing loading bar (Safari) until they time out. Activity monitor shows the transfer drop from 12 MB/s to a few KB/s.

    Infuriatingly the only means of resolution is a reboot. :mad:

    I have read about a new "feature" which does some arp validation and is known to throw up regular false positives which cause issues but why that should cause anything more than that TCP connection to lock - as opposed to locking the entire stack is beyond me, plus I'm not yet convinced that that is the problem here as I'm connecting through my home router (Virgin Media Superhub) and not a double redundant gateway (which is what causes the arp validation to fail).

    Anyone else having this issue? I can't believe I'm the only one who is constantly getting these failures in Mavericks :(
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Wifi or ethernet?

    I've noticed (I assume its a but with 10.9.1) that while on wifi my network drops for a second or two, which is enough to impact downloads if I was doing any.
     
  3. headfuzz thread starter macrumors 6502

    headfuzz

    Joined:
    Apr 13, 2007
    Location:
    Brighton, UK
  4. headfuzz thread starter macrumors 6502

    headfuzz

    Joined:
    Apr 13, 2007
    Location:
    Brighton, UK
    #4
    Although I should add the ethernet is a Thunderbolt to ethernet dongle (Apple original) due to the lack of ethernet port on the 13" rMBP.
     
  5. headfuzz thread starter macrumors 6502

    headfuzz

    Joined:
    Apr 13, 2007
    Location:
    Brighton, UK
    #5
    So another weird aspect is Spotify will continue to stream songs that aren't cached quite happily.

    wget sits there when you try to grab the url and doesn't complete the HTTP connection, in much the same way as browsers will sit there doing very little.

    Very odd. I guess some wiresharking is called for before I do a clean install or, failing that, restore my Mountain Lion image.

    Frustrating does not begin to cover it.
     
  6. poorcody macrumors 6502

    poorcody

    Joined:
    Jul 23, 2013
    #6
    I had similar problems until I implemented the ARP workaround. Like you said, I don't see why the ARP bug would affect a residential cable connection like mine, but the difference was instant. I couldn't download a 4GB file from DropBox despite trying for days. After the fix, it worked the first time.

    I used the fix described here. Pretty simple to do/undo so worth a shot:
    http://www.macstadium.com/blog/osx-10-9-mavericks-bugs/
     

Share This Page