Network interface not responding on 13" Retina MacBook Pro

Discussion in 'OS X Mavericks (10.9)' started by J. J., Nov 28, 2013.

  1. J. J. macrumors regular

    J. J.

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #1
    Hello. Since about one month - after having installed OS X Mavericks - about once every two weeks my MacBook Pro disconnects from the internet and the Wi-Fi menu in the menu bar doesn't respond (I get a spinning wheel of death if I click on it). I have to reboot to temporary resolve the issue. Also, if, after the network as stopped responding, I put my mac to sleep it fails to wake and it reboots (see log below).
     

    Attached Files:

  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    I bet you have iCloud turn on.

    Now I heard a crazy simple but somewhat scary possible fix. So follow these steps:

    1. Open System Preferences->Network pane and in select your wireless card and use that pane to disconnect from your wireless.

    2. Now make sure your wireless card is selected and at the bottom left of the pane click the - sign (Don't panic). Then wait about 30 seconds before proceeding to the next step.

    3. Now in the Main Network Pane click the + button now to add back your wireless card. Then immediately save this new entry by click the 'Apply' button.

    4. Now rejoin your wireless network from inside the Network pane.

    See if this helps, Good Luck.
     
  3. J. J. thread starter macrumors regular

    J. J.

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #3
    I'll try this the next time it stucks. Thank you
     

Share This Page