Network Macs show up twice

Discussion in 'macOS' started by Me1000, Dec 8, 2007.

  1. Me1000 macrumors 68000

    Me1000

    Joined:
    Jul 15, 2006
    #1
    So my network is now exclusively Mac, yet in the sidebar in the Finder all my network Macs show up twice, but the 2nd one always has the BSOD icon,

    [​IMG]


    The MyBookWorld is my NAS drive that always shows up as a windows server because it has to connect via SMB...

    Anyone have any idea how to get my Macs to show up only once though?
    Besides it looks ugly with all those BSODs on the side,
    :)
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    If you have enabled several network protocols on a computer, then you can expect each detected protocol to display as a separate entry. If you are running a homogeneous Mac network, then AFP is sufficient. You should disable SMB/CIFS.
     
  3. Me1000 thread starter macrumors 68000

    Me1000

    Joined:
    Jul 15, 2006
    #3
    That is what I thought at first, however after going to system preferences (in "Sharing")

    when I click "options" under "File Sharing" only AFP is checked, my other 2 options are SMB and FTP, which are both off.

    Is there somewhere else where some other protocol may be turned on?
     
  4. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #4
    It's not just about Sharing. Check Directory Access.
     
  5. Me1000 thread starter macrumors 68000

    Me1000

    Joined:
    Jul 15, 2006
    #5
    Where would I locate that? Because it isn't in System Preferences,
     
  6. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
  7. Me1000 thread starter macrumors 68000

    Me1000

    Joined:
    Jul 15, 2006
    #7
    I opened up Directory Utility and looked around, but I didnt see anything there at all turned on, however Im not 100% sure exactly what I am looking for...
     
  8. Me1000 thread starter macrumors 68000

    Me1000

    Joined:
    Jul 15, 2006
  9. tomacintosh macrumors regular

    Joined:
    Aug 25, 2005
    #9
    I'm also having the same problem? Has anyone found out how to stop it?
     
  10. quitexander macrumors newbie

    Joined:
    Jun 8, 2008
    #10
    Possible Solution to the problem...

    I found that the interface for SMB sharing is kind of klutzy. To solve the problem on my computer I went to Sys Prefs, then File Sharing, then File Sharing line, then clicked the options button. At this point it looked like I only had AFP turned on, as it was the only one of the top three checkboxes checked and my account was checked in the inset box below (see first picture). Through sheer blind guessing I discovered that by unchecking this tick box in the inset window, next to my account name, I was then prompted to enter my password to turn off SMB file sharing (see second picture).
    After turning airport off and on again to reset the bonjour shares this has solved the problem; now only the macs on my network show up and all with the correct icons, info etc.


    Scratch that. It merely seems to delay them turning up in the sidebar, NOT eliminate them. Devices still show up twice; once as per normal and once as their mac addresses. Apologies for any false hope.
     
  11. Madam Bomb macrumors newbie

    Joined:
    Jul 13, 2009
    #11
    Same issue

    I"m having the same issue. Any definitive answer on this?

    Thanks in advance.

    MB
     
  12. msmith2112 macrumors 6502

    msmith2112

    Joined:
    Sep 17, 2002
    #12
    I think it's because you have printer sharing enabled. I haven't figured out why, though.
     
  13. marzy macrumors member

    Joined:
    Jan 15, 2007
    Location:
    Australia
    #13
    Weird, I only get this "problem" (guess it's not really a problem) when I turn SMB sharing on.
     
  14. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #14
    Disabling Printer Sharing should cause the other icon to disappear (if it doesn't, disable it then restart). Not sure if it's a bug or its intended purpose.

    Also, as some people said, it can be affected by SMB sharing (if not turn File Sharing off completely to see if it is related). Try both and report your findings!
     
  15. designs216 macrumors 65816

    designs216

    Joined:
    Oct 26, 2009
    Location:
    Down the rabbit hole
    #15
    I couldn't get the second entry to disappear until I unchecked "Time Machine Support". Yeah, I know it's an old thread but thought folks would like to know.
     

Share This Page