Network not working correctly after upgrading my MB Air 2013

questionwonder

macrumors member
Original poster
May 6, 2013
59
10
I recently upgraded my Mid 2013 Macbook Air to Sierra and I started having network/internet issues.

Here are my symptoms.
1. I'll open websites in Chrome/Safari and the page will delay it's load, sometimes I'll have to wait 60 seconds and then hit the refresh button.
2. If I'm streaming cams from a cam site. The streaming will stop on all the cams for roughly 60+ seconds then start up again. Usually I'll have to refresh the page to start streaming cams again.
3. In Youtube, videos stop playing

In most cases, in order to start the internet up again, I have to go into "Network Preferences" click on "Assist Me" then click "Diagnostics" and here is what I see. "Internet" and "Server" are yellow.

Screen Shot 2017-06-23 at 1.22.02 PM.png

So then I click "Continue" and then I click "Continue" again to refresh the setting and "Internet" and "Server" change from yellow to red!

Screen Shot 2017-06-23 at 1.22.33 PM.png


Within a minute or two all buttons turn green again. But this is very annoying!! I tried deleting some of the caching files for the network according to certain pages I googled, but it didn't seem to help.

Anyone else know what's going on or how to fix this? I didn't have this issue with the previous MacOSX install.
 

Taz Mangus

macrumors 68040
Mar 10, 2011
3,285
375
It sounds like you did not do a clean install. My suggestion as a sanity check is to create a new partition on your internal hard drive and do a clean install of Sierra to the new partition, leave the install clean. Boot to the new partition and see if you still have the issues with WiFi. If you don't than the WiFi issue you are having are related to what you have installed. When you are done, boot back to your primary partition and delete the new partition.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,176
8,823
California
I recently upgraded my Mid 2013 Macbook Air to Sierra and I started having network/internet issues.
I sounds like you may some sort of third party utility or AV suite running that is not compatible with Sierra.

As a test, reboot and hold the shift key at startup to boot to safe mode. That will stop any utilities like that from running. Does it work okay in safe mode?

If it does, then reboot and run the app Etrecheck. That will create an anonymized report showing everything launching. You can post that here for us to take a look.
 

questionwonder

macrumors member
Original poster
May 6, 2013
59
10
Hi. Here is my etrecheck report. It shows a spigot and bitware file as being adware/malware but I'm not sure if this is what's affecting my internet!?

EtreCheck version: 3.4 (420)

Report generated 2017-06-25 16:13:46

Download EtreCheck from https://etrecheck.com

Runtime: 1:55

Performance: Excellent



Click the [Lookup] links for more information from Apple Support Communities.

Click the [Details] links for more information about that line.

Click the [Remove/Report] links to remove adware or update the whitelist of legitimate software.



Problem: Other problem

Description:

internet has intermittent connection issues



Hardware Information:

MacBook Air

[Technical Specifications] - [User Guide] - [Warranty & Service]

MacBook Air - model: MacBookAir6,2

1 1.7 GHz Intel Core i7 (i7-4650U) CPU: 2-core

8 GB RAM Not upgradeable

BANK 0/DIMM0

4 GB DDR3 1600 MHz ok

BANK 1/DIMM0

4 GB DDR3 1600 MHz ok

Bluetooth: Good - Handoff/Airdrop2 supported

Wireless: en0: 802.11 a/b/g/n/ac

Battery: Health = Normal - Cycle count = 471

iCloud Quota: 1.01 GB available


Video Information:

Intel HD Graphics 5000 - VRAM: 1536 MB

Color LCD 1440 x 900


Disk Information:

APPLE SSD SM0512F disk0: (500.28 GB) (Solid State - TRIM: Yes)

[Show SMART report]

EFI (disk0s1 - MS-DOS FAT32) <not mounted> [EFI]: 210 MB

(disk0s2) <not mounted> [CoreStorage Container]: 499.42 GB

Recovery HD (disk0s3 - Journaled HFS+) <not mounted> [Recovery]: 650 MB


USB Information:

USB30Bus

Apple Inc. BRCM20702 Hub

Apple Inc. Bluetooth USB Host Controller


Thunderbolt Information:

Apple Inc. thunderbolt_bus


Virtual disks:

Macintosh HD (disk1 - Journaled HFS+) / [Startup]: 499.05 GB (157.14 GB free)

Physical disk: disk0s2 499.42 GB Online



System Software:

macOS Sierra 10.12.5 (16F73) - Time since boot: about 6 days


Gatekeeper:

Mac App Store and identified developers


Possible adware:

Adware: ~/Library/LaunchAgents/com.bittorrent.BitTorrent.plist

Adware: ~/Library/LaunchAgents/com.spigot.ApplicationManager.plist

2 possible adware files found. [Remove/Report]


Kernel Extensions:

/Applications/VMware Fusion.app

[loaded] com.vmware.kext.vmci (8.5.7) [Lookup]

[loaded] com.vmware.kext.vmioplug.15.2.0 (8.5.7) [Lookup]

[loaded] com.vmware.kext.vmnet (8.5.7) [Lookup]

[loaded] com.vmware.kext.vmx86 (8.5.7) [Lookup]



/Library/Extensions

[loaded] com.intel.kext.intelhaxm (6.0.5 - SDK 10.9) [Lookup]



System Launch Agents:

[not loaded] 6 Apple tasks

[loaded] 167 Apple tasks

[running] 109 Apple tasks


System Launch Daemons:

[not loaded] 42 Apple tasks

[loaded] 166 Apple tasks

[running] 110 Apple tasks


Launch Agents:

[running] com.bjango.istatmenusagent.plist (? ? ? - installed 2016-07-25) [Lookup]

[running] com.bjango.istatmenusnotifications.plist (? ? ? - installed 2016-07-25) [Lookup]

[running] com.bjango.istatmenusstatus.plist (Marc Edwards - installed 2016-07-25) [Lookup]

[running] com.epson.Epson_Low_Ink_Reminder.launcher.plist (EPSON - installed 2015-12-12) [Lookup]

[running] com.epson.ecrp.launcher.plist (EPSON - installed 2015-12-13) [Lookup]

[loaded] com.epson.esua.launcher.plist (Seiko Epson Corporation - installed 2017-06-08) [Lookup]

[running] com.epson.eventmanager.agent.plist (Seiko Epson Corporation - installed 2017-01-09) [Lookup]

[running] com.epson.scannermonitor.plist (Seiko Epson Corporation - installed 2017-01-09) [Lookup]

[loaded] com.oracle.java.Java-Updater.plist (? 830d5b12 be93c7fb - installed 2017-03-05) [Lookup]


Launch Daemons:

[loaded] com.adobe.fpsaud.plist (? 2afb3af7 a0305b84 - installed 2017-06-14) [Lookup]

[running] com.bjango.istatmenusdaemon.plist (Marc Edwards - installed 2016-07-25) [Lookup]

[loaded] com.intel.haxm.plist (Shell Script 42f307e7 - installed 2016-11-17) [Lookup]

[loaded] com.microsoft.autoupdate.helper.plist (Microsoft Corporation - installed 2017-06-08) [Lookup]

[loaded] com.microsoft.office.licensing.helper.plist (? 6d8cb30e 9c3f8304 - installed 2014-11-06) [Lookup]

[loaded] com.microsoft.office.licensingV2.helper.plist (? 689758eb 56e8a673 - installed 2015-07-01) [Lookup]

[loaded] com.oracle.java.Helper-Tool.plist (Shell Script e3fefdd2 - installed 2016-12-12) [Lookup]


User Launch Agents:

[loaded] com.bittorrent.BitTorrent.plist (BitTorrent, Inc - installed 2016-03-25) Adware! [Remove/Report]

/Applications/BitTorrent.app

[loaded] com.google.keystone.agent.plist (Google, Inc. - installed 2017-03-28) [Lookup]

[loaded] com.pia.pia_manager.plist (? 96c13967 0 - installed 2016-12-10) [Lookup]

[running] com.spigot.ApplicationManager.plist (? af207fd6 217327b7 - installed 2017-01-25) Adware! [Remove/Report]

~/Library/Application Support/Spigot/ApplicationManager


User Login Items:

VMware Fusion Start Menu Application

(/Applications/VMware Fusion.app/Contents/Library/VMware Fusion Start Menu.app)

WDDriveUtilityHelper Application

(/Applications/WD Drive Utilities.app/Contents/WDDriveUtilityHelper.app)


Internet Plug-ins:

FlashPlayer-10.6: 26.0.0.131 (installed 2017-06-18) [Lookup]

QuickTime Plugin: 7.7.3 (installed 2017-06-06)

Flash Player: 26.0.0.131 (installed 2017-06-18) [Lookup]

JavaAppletPlugin: Java 8 Update 121 build 13 (installed 2017-03-05) Check version

SharePointBrowserPlugin: 14.4.6 (installed 2014-11-20) [Lookup]



User internet Plug-ins:

npNASAEyes: NASAEyes_x86_64 1.0.0.0 (installed 2016-01-31) [Lookup]

PanasonicDrmPlugin_3: 3.0.1.1 (installed 2015-07-22) [Lookup]



Safari Extensions:

[enabled] Adblock Plus - Eyeo GmbH - https://adblockplus.org/ (installed 2017-06-12)

[disabled] Grammarly for Safari - Grammarly - https://www.grammarly.com (installed 2017-06-12)


3rd Party Preference Panes:

Flash Player (installed 2017-06-14) [Lookup]

Java (installed 2017-03-05) [Lookup]


Time Machine:

Time Machine not configured!



Top Processes by CPU:

4% WindowServer

2% kernel_task

0% fontd

0% launchservicesd

0% WDDriveUtilityHelper


Top Processes by Memory:

856 MB kernel_task

613 MB BitdefenderVirusScanner

254 MB Google Chrome

190 MB Messages

189 MB Google Chrome Helper


Top Processes by Network Use:

Input Output Process name

6 MB 3 MB mDNSResponder

590 KB 338 KB netbiosd

96 KB 114 KB apsd

4 KB 4 KB ntpd

0 B 6 KB SystemUIServer


Top Processes by Energy Use:

6.94 WindowServer

0.64 Ecrp

0.60 sysmond

0.52 EEventManager


Virtual Memory Information:

3.53 GB Available RAM

525 MB Free RAM

4.47 GB Used RAM

3.02 GB Cached files

59 MB Swap Used


Software installs:

Microsoft AutoUpdate: (installed 2017-06-04)

Microsoft AutoUpdate: (installed 2017-06-08)

EPSON Software Updater: (installed 2017-06-08)

Adobe Flash Player: (installed 2017-06-13)

Adobe Flash Player: (installed 2017-06-18)



Install information may not be complete.


Diagnostics Information:

2017-06-25 15:46:26 BitdefenderVirusScanner.app High CPU use [Open] [Details]