Network only works when using chrome

Discussion in 'OS X Yosemite (10.10)' started by stuttboksa85, Sep 5, 2014.

  1. stuttboksa85 macrumors newbie

    Joined:
    Sep 5, 2014
    #1
    Hi! I have a strange issue. I can only browse online when using Chrome. Safari does not work. Firefox does not work. My fpt programs does not work. Mail app does not work. My iCal cant sync. Basically I'm in stone age if I don't use chrome :p I've tried two different networks so the problem is probably not the connection. The network indicator shows that I'm online. What happens when I use Safari is that the blue loading indicator goes up to about 4cm and then stops. (see attachment) I've had Yosemite sins the PB was released and this problem occurred recently. I've had to refresh the Safari a bit earlier to kick start it but it has worked after a few refreshes but not anymore.

    Any idea what the problem could be?
     

    Attached Files:

  2. airlied macrumors 6502

    airlied

    Joined:
    Jul 8, 2011
    #2
    It's not strange, I got the same issue too. Yosemite has DNS service bugs since DP1. Chrome has its own DNS server. Go to WIFI settings (or any network settings you use) and add 8.8.8.8 and 8.8.4.4 and 2001:4860:4860::8888 and 2001:4860:4860::8888 to your DNS list (they are all google dns servers).
     
  3. tongefactor40 macrumors regular

    Joined:
    Jun 24, 2010
    #3
    I had the same issue when VPN was on. DNS might be a fix too.
     
  4. stuttboksa85 thread starter macrumors newbie

    Joined:
    Sep 5, 2014
    #4
    Thank you soon much!! It didn't work right away but when i restarted my mac everything was working perfectly! Thank you again! #9september<3
     
  5. anyjungleinguy macrumors regular

    Joined:
    Mar 6, 2012
    #5
    Yup, I also have this but only when I connect through a VPN.

    Happens with both Yosemite's in built client and Tunnelblick.
     

Share This Page