Network Preferences Issues

Discussion in 'MacBook' started by AliKipp2008, Jan 12, 2013.

  1. AliKipp2008 macrumors newbie

    Joined:
    Jan 12, 2013
    #1
    Ok so i bought my Macbook back in 2008, have had NOOOO problems with untill a couple weeks ago. Didn't use the Macbook for 3 months due to charger breaking, bought a charger and tried hooking up to the library wifi and couldnt connect because of a library wifi issue. I thought it was my computer because the airport in the top right corner was showing full signal but wouldnt connect. Did some research and found something that told me to remove system configurations to trash and reboot computer, I did that and after rebooting i tried to get into Network setting in the System Prefrences folder, it would just not open at all, i just got the rainbow spinny disk and said there was some kind of error. Did some research online (my apple warrinty has run out) and figured out how to get the Network setting to not freeze and open, by deleting PRAM.Airport, the Netowrk setting now opens but everything in it is gone... There is no Aiport, Ethernet, No Network Services. All Locations have disapeared, and when i click the + button where the Network Services would be it just freezes/ doesnt open. Once again I've been researching how to fix my problem with no success yet, some say it can be fixed manually some say it needs to go to the Apple store. I'm unsure of whats going on but i believe i deleted the configurations for my Network Settings.

    Does anyone have any advice on how to fix this? Or have had similar problems in the past and can help me?
    Thank you guys!! PLEASE HELP ME!!:eek::mad:
    Ali
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    Could be signs of a failing hard drive or corruption in the OS.

    Back it up, Time Machine would be a good choice, and reinstall your OS or something newer.
     
  3. praktical macrumors regular

    praktical

    Joined:
    Mar 12, 2012
    Location:
    Oklahoma City Oklahoma.
    #3
    Network issues

    I have no idea why in the world any suggestion would be made to remove system config. Did you empty the trash? If not it would be wise to replace. Are you using DHCP or manual ip address? Your network issue might be with your wifi access point rather than your MacBook. I would start there. If you're not able to replace the file then I suggest you do a full reinstall and start trouble shooting from the access point through to your MacBook.
     
  4. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #4
    It's possible there are some corrupted sector's on the hard drive causing these problems. Hopefully you have a good back up already established.

    To maintain and repair hard drives, I actually use a PC DOS-based program called Spinrite as a maintenance utility and data recovery utility on all my HDD's. You have to have an IBM-PC in order to use it though. You take the HDD out of the Mac and connect it to the IBM-PC and run the program. Below is my old MBP HDD in a Dell PC with Spinrite working on it.

    [​IMG]

    [​IMG]
     
  5. AliKipp2008 thread starter macrumors newbie

    Joined:
    Jan 12, 2013
    #5
    yea idk i wish i didnt remove anything cause there would be no problems i think, later int he day i found out it was the wifi not working.
    i did not empty the trash after i rebooted the computer i took it out of the trash and everything worked except the networks app it wouldnt opened, i finally got it to open by deleteing another file but now everything the the network setting is gone theres absolutley nothing in it. everything else is fine except the network.

    ----------

    can you restore to factory settings with out the disk that came with it???
     

Share This Page