Network problem Panther/Linux

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by twentyfour, Nov 17, 2003.

  1. twentyfour macrumors newbie

    Nov 6, 2003
    I have a problem connecting to my Linux (RedHat) server from Panther. I am using Cmd-K to connect, it will recognize my server, even show my shares there, then connect and disconnect a second later. Sometimes it shows an Alias on both desktop and sidebar of the finder.

    I have been using smb://... and afp://... to connect. Both won't work. Apple Talk is activated.

    Funny thing: It all works fine from OSX 10.2.6.

    The only thing that helps is to start classic and connect through the chooser or network utility - that works fine and once I have done that, I can even quit Classic, it will keep the connection on the OSX finder.

    I am reading all these articles about how easy it is to connect to a server from OSX. Ha ha.

    Anyone out there more expert than me (frankly, I'm not at all, I am a designer and I feel pretty stupid with all this system stuff)?
  2. Nik_Doof macrumors regular

    Sep 15, 2003
    St Helens, UK
    with samba make sure ur using a correct username/password for the server, if samba is setup to use PAM and /etc/passwd, just try ur username as root and ur root password...if that works its just a matter of adding a user.

    Check out the O'rielly samba books and the howtos on the internet, they are very good :)
  3. daveL macrumors 68020


    Jun 18, 2003

    Why not use NFS? Seems weird to use a MS protocol to share file systems between two varieties of Unix.
  4. twentyfour thread starter macrumors newbie

    Nov 6, 2003
    OK, let me point out the real problem once again.

    I HAVE been using our Linux server for quite a while now, with both OS 9.x and OSX 10.2.x. No problem, very stabil. We have been using AFP protocoll, but SMB also works (slower and some limitations apply when ich comes to file names etc.).

    The problems came with 10.3. In the meantime I had my system supporter here and he did some amendments and loaded the latest updates onto the Linux server, and we are now able to establish a connection from 10.3. But it's extremely unreliable, it would even destroy or delete files that we save on the server using the save command from certain applications. Nobody was able to help us - not even Apple.

    I think I need to get rid of the Linux File server.
  5. tibook-g macrumors newbie

    Jan 7, 2004
    Did you solve the problem?

    I´ve run into the same problem. But it startet after the mac went into 'sleeping-mode' (sorry don´t know the english word -> i´m using a german system).

    No chance to connect to our server (a debian one 'woody') by afp or smb.

    But after 2 days of trying this and that i´ve 'checked' the AppleTalk where you deal the ethernet-things (it wasn´t nessecary under 10.2.x) and connectet to our server over the finder -> Network -> local -> our server -> and then you enter your name + passw...

    For me it works hope for you two.

    Best greetings from Hamburg Germany
    Andreas (a designer too ;)
  6. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW
    What version of Red Hat is on the file server? Was the file server upgraded recently? Are both computers on the same subnet or network, or is the file server remote? Any network appliances of any sort between you and the file server?

    We just upgraded our Linux servers to "r-hell" (Red Hat Enterprise Linux), and I haven't had any problems staying connected to their Samba shares from my Powerbook (running 10.3.2). But I'm in the same building when I'm doing that.
  7. twentyfour thread starter macrumors newbie

    Nov 6, 2003
    solved it the hard way

    In the meantime, my system administrator found a way to make it work somehow - but the connection from 10.3 to the Linux server is very unreliable - we even lost files. The problem becomes really dramatic when we work with Quark XPress 6 or Freehand MX - those applications sometimes even delete files from the file server! Especially Quark 6 is a real pain.

    We have solved the file server problem in the meantime by simply replacing the Linux machine by a NAS server - plug and play, easy to administrate, works perfect. This thing seems to be designed for Mac users ...
    We still use the Linux server, though, but only as a web server.
  8. twentyfour thread starter macrumors newbie

    Nov 6, 2003
    tibook-g's question

    Hallo Andreas

    I'm using a german system as well, since I live in der Schweiz, but let's keep this in english, so anyone else interested can follow as well:

    It seems normal to me that you lose the network connections after falling into sleeping mode - same thing happens to me. But usually it's no problem to reconnect afterwords.

    But if the connecting mode via the "Netzwerk" control panel works for you - fine. I guess that's what Apple suggests anyway. For me, none of those modes worked on the Linux server.

    But as I wrote in an earlier post, we solved the problem by simply buying a new (very inexpensive) NAS server that we are now using as a file server.

    Since you are a designer - are you working with Quark 6? If yes, no problems with saving files to the Linux server?
  9. tibook-g macrumors newbie

    Jan 7, 2004

    Hallo back ;),

    no we´ve changed from Quark to Indesign because our business is much more web than print. And with Freehand MX until now no problems.

    Thanx for your reply -> Best greetings to switzerland ;).
  10. twentyfour thread starter macrumors newbie

    Nov 6, 2003
    Freehand: What are your experiences with font handling? We found out that Freehand does not support font families, but lists every single font in a LONG list. Did you find a solution for that - or are you not working with a lot of fonts?
  11. twentyfour thread starter macrumors newbie

    Nov 6, 2003
    ... and Indesign: We are seriously thinking about switching to Indesign - which would be a huge step for us since we do several magazines and a lot of print stuff.
    Do you experience any problems with saving files to and opening files from the Linux server? Any instabilities like in Quark 6 (which is a pain)? In the past, one of the main reasons why we stayed with Quark was speed - Indesign used to be a lot slower. Is that better in the latest version? (Are you working with CS yet?)

Share This Page