Network service order

Discussion in 'macOS' started by eXan, Jan 13, 2008.

  1. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #1
    Both of my Macs are connected to my AirPort network that is connected to the DSL.

    Sometimes I use Ethernet cable to transfer large amounts of data between these two computers, connecting them directly - each end of cable goes directly to the computers' ethernet port.

    Usually the cable is staying connected to the iMac, but I dont like extra cables sticking out of my MacBook so I connect it only when necessary.

    So my problem is: when I want to transfer quite a few GBs of data I connect the ethernet cable to MacBook and browse the network for my iMac. All while I'm connected to my wi-fi. This worked, untill I upgraded to Leopard.

    I have Ethernet above the AirPort in the service list order, but it just refuses to work. When I turn AirPort off it works, but I dont want to turn it off every time! (like when I'm downloading smth from the internet).

    Do you know what the matter, or is it just Leopard being buggy? :confused:
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    Interestingly, I do almost this exact thing as well, and I was just marveling recently at how it works without hiccup, including if I'm in the middle of a network action (playing a video off a mounted server, in particular, though Internet actions also work fine).

    I'm running 10.5.1 on the laptop I'm adding the temporary hard connection to (10.4.11 on the in-house server I'm connecting to). The only difference in my setup is that I'm running the connection through an Airport router (gigabit ethernet model).

    I'm guessing that's the difference--the bridge remains the same in my version, and the IP address of the computer I'm connecting TO doesn't change (and of course in my case it doesn't matter if I turn Airport off since I can still see the internet through the wired connection).

    How about this to try: Set a fixed network address on the wired connection on each computer (say, 192.168.0.1 and .2, or something different if your Airport is already using those addresses), then connect directly to that IP address using the Finder. That will, hopefully, force a connection via the wire to the Mac you're transferring to without affecting the Airport connection.

    I've doing something almost exactly like that at work with a server that has two Ethernet ports--I can connect to stuff on one internal network without affecting the second.

    If that doesn't work, you could also try turning on Internet sharing (from Airport to Ethernet) on the desktop Mac, which should keep your internet connection running through the wired connection even if you turn off Airport.
     
  3. eXan thread starter macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #3
    Well, oddly enough it all of the sudden started working :confused: I didn't change any settings or restart my Macs. Now it seems extremely suspicious!

    Hope it just keeps working now :eek:
     

Share This Page