"Network settings have been changed"

Discussion in 'Mac Apps and Mac App Store' started by geoffhulme, Aug 23, 2009.

  1. geoffhulme macrumors newbie

    Joined:
    Aug 23, 2009
    #1
    My Network settings Pref Pane always shows the message "Your network settings have been changed by another application" and I can only get out of this pane by force-quitting the System Prefs. application. Can anybody help me sort this out. Have OSX 10.4.11 on an eMac.
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Simple fix is to go into the Security preferences, and enable the option for "Require password to unlock each System Preferences pane." Longer fix would involve creating a new network location, pulling the preferences.plist from /Library/Preferences/SystemConfiguration, restarting and re-configuring your computer's network settings.
     
  3. geoffhulme thread starter macrumors newbie

    Joined:
    Aug 23, 2009
    #3
    Network settings

    Fix worked. thank you, thank you.
     
  4. lolcaption macrumors newbie

    Joined:
    Nov 13, 2009
    #4
    Hi All,

    I had this same problem recently I tried the lock settings trick but it didn't work for me. I found another fix that did work:

    Go to Library/Preferences/SystemConfiguration and delete the following (suggest make copies to the desktop first if in doubt):

    com.apple.airport.preferences.plist
    NetworkInterfaces.plist
    preferences.plist
    com.apple.nat.plist


    All these files will regenerate as necessary. If you're using Airport or Internet Sharing you'll have to reestablish the appropriate settings.

    Thanks to Maddog who originally found the fix.
     

Share This Page