Network Shared Folder Connection Issue

Discussion in 'OS X El Capitan (10.11)' started by RumorzGuy, Oct 11, 2015.

  1. RumorzGuy, Oct 11, 2015
    Last edited: Oct 11, 2015

    RumorzGuy macrumors 6502

    RumorzGuy

    Joined:
    Sep 17, 2008
    Location:
    Guam, Mariana Islands, U.S.A.
    #1
    Greetings once again,

    Lately, I have been having a persistent problem with accessing one of my network shared folders. This particular folder resides inside Mountain Lion, which itself runs as a VM inside of VirtualBox. Being as Mountain Lion is a guest system running inside of VirtualBox, it is treated as another volume by El Capitan on my machine, even though both VirtualBox and Mountain Lion run on this same machine.

    Sometimes the shared folder works without a problem, and sometimes it doesn't. When it doesn't work, the on-screen error message I receive is the following:

    "The operation can’t be completed because the original item for “[Shared Folder Name Here]” can’t be found."

    What is odd about this is that if I click on the "Network" option under the "Go" menu on the El Capitan side, the network volume -- meaning Mountain Lion -- mounts in the Finder just fine, and I see the shared folder listed underneath it. However, whenever I double-click the shared folder in order to mount it on my desktop -- as it usually does -- that is when I receive the on-screen error message noted above.

    Sometimes, all I have to do in order to correct this problem, is to remove the aforementioned shared folder from the list in the "Shared" preferences pane on the Mountain Lion side, close the "Systems Preferences" app, open "System Preferences" again, go to the "Shared" preferences pane again, and re-add the same shared folder.

    This has worked until now. However, this time, no matter how many times I remove and re-add the shared folder to the list, I still keep getting the same error message, even though I can plainly see the shared folder in the list under "Mountain Lion" when I use "Go/Network" on the El Capitan side.

    So this time I went even further. I shut down my Mountain Lion virtual machine, and I shut down VirtualBox as well. I then relaunched VirtualBox and started the ML VM again. Still no dice!

    So, I really went to the extreme this time, and shut down every app on my computer, and then shut down my computer as well. No, I didn't choose "Restart"; I chose "Shut Down . . ." so I could get a cold start.

    Despite doing all of that, and then relaunching VirtualBox and starting my Mountain Lion virtual machine, the problem is STILL not resolved. Now I am getting this on-screen error message:

    "The operation can’t be completed."

    "An unexpected error occurred (error code 0)."

    To make matters worse, in the latest episode of this bizarre behavior, while my network shared volume still mounts in the Finder when I use "Go/Network" under El Capitan, when I use the shared volume's disclosure triangle, the shared folder is no longer even being listed.

    So, now I have gone into Mountain Lion, removed the shared folder from the list in the "Shared" prefs pane -- as before -- physically deleted the shared folder, made a new one, even giving it a new name, and re-added it to the shared folder list, and still nothing. It still refuses to show up under my network shared volume when I use "Go/Network".

    And, BTW, yes, I have both read and write privileges for the shared folder and all of its contents.

    I have run out of ideas. I don't know why it was working just fine until a day or two ago, and now it is not.

    Any ideas what is causing this to occur?

    Thanks in advance.

    UPDATE #1:

    Here is the weird thing. From my Mountain Lion VM, I can access the shared folder which I set up in El Capitan, but from El Capitan, I cannot access the shared folder that I set up in Mountain Lion. So what gives here? As I said in my original post, it is not a permissions issue, because I have both read and write permission for the shared folder that is on the Mountain Lion side. I should also note that since writing my original post, I have also turned off Little Snitch's network filter -- which did not help -- and I have also restarted my wi-fi router, which also did not help.
     
  2. Mac-Joe macrumors newbie

    Mac-Joe

    Joined:
    Jul 25, 2011
    Location:
    Austria
    #2
    Good Day People,

    simular problems here specialy with the network... why is it everytime apple releases a new OS we get thrown back to the issues we had years ago !?!?!?!?... if I would do my job like apple does its OS I would be fired in a hearbeat. The main reason I am pissed of is because I am trying to my mac as a real working machine not a drooling device... I do not have time for these network issues/problems bull crab to which apple keeps say "oh we fix everything, we make better"... apple you did nothing... you worry more about 1$ than 1000 unsatisfied customers.
     

Share This Page