Network sharing issue

Discussion in 'MacBook' started by testcard, Dec 29, 2009.

  1. testcard macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #1
    The problem is that my 2009 MacBook doesn't like sharing my home wi-fi network with either my iPod Touch or my new iPhone 3GS. My router is a Netgear DG834GT with latest firmware. If I turn on either the Touch or the iPhone, the MacBook looses its connection and tells me "Another device is using your computer's IP address (xxx.xxx.x.x)". I'm not an expert on either routers or AirPort so I've avoided tinkering with the settings, but I'm sure the solution is very simple! Would appreciate any help in getting my all three to share my network without causing issues. Thanks.
     
  2. toolbox macrumors 68020

    toolbox

    Joined:
    Oct 6, 2007
    Location:
    Australia (WA)
    #2
    Your DG834 - Do you have DHCP server set up on there? Sounds like you have all the computers set as static ip's Only one computer on the network can have one unique address basically

    Computer 1 is the only one that can have 192.168.1.2
    Computer 2 is the only one that can have 192.168.1.3

    If these two machines have the same IP, you will get errors like IP conflicts/computers not connecting properly
     
  3. testcard thread starter macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #3
    I'm not sure this helps, but in the Netgear settings > Use Router as DHCP Server", this option is ticked.

    Edit: Just looked at wi-fi settings on the iPhone under DHCP. IP address is showing as 192.168.0.2
    In the same settings on iPhone, Router is showing as 192.168.0.1
    Going into AirPort, IPv4 is showing 192.168.0.3
    Just turned on MacBook and as soon as it connected to the router, it knocked out the wi-fi connection to the iPhone.
     
  4. toolbox macrumors 68020

    toolbox

    Joined:
    Oct 6, 2007
    Location:
    Australia (WA)
    #4
    What is the Ip address of the macbook?

    The modem looks as follows, your settings will be different to mine
     

    Attached Files:

  5. testcard thread starter macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #5
    Does this help:
     

    Attached Files:

  6. toolbox macrumors 68020

    toolbox

    Joined:
    Oct 6, 2007
    Location:
    Australia (WA)
    #6
    All looks good there, sounds to me like a IP conflict What IP does your macbook have? What IP does the iphone have

    Actually edit that, if your DHCP range is 192.168.0.2 - 192.168.0.254, That means there are 254 possible ips that your computers will get assigned.
     
  7. testcard thread starter macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #7
    Thanks for the replies toolbox. But it gets more confusing. I just checked the IP address of the MacBook and AirPort showed it as 192.168.0.2. I switched off AirPort and then turned on wi-fi on the iPhone - IP was 192.168.0.2 on the phone. I turned the iPhone wi-fi off, and turned AirPort back on and this time it was showing IP as 192.168.0.3. Should the Netgear be assigning different IP addresses each time to the same device?
    Edit:Earlier I managed to have both the MacBook and the iPhone sharing the Netgear connection. I put the MacBook to sleep, then woke it. As soon as it awoke, it lost its connection.
     
  8. toolbox macrumors 68020

    toolbox

    Joined:
    Oct 6, 2007
    Location:
    Australia (WA)
    #8
    Yes the netgear should be assigning IPs. Sounds like from what you have posted your getting ip conflicts.

    Can you set your ip's statically? You will need your ISP's DNS settings. GO into system preferences, open network and select the airport and click on advanced

    Click on TCP/IP - Drop down the menu and select Manually enter in the following

    IP - 192.168.0.100
    Submask - 255.255.255.0
    Gateway - 192.168.0.1

    Click on the DNS Tab

    Click the + sign and enter in the Primary DNS of your ISP, then click the plus sign again and enter in the secondary dns of your ISP

    Click OK then apply. See what happens.
     
  9. testcard thread starter macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #9
    Thanks for the advice, and I'll try this. Before I do, could you clarify something?
    In the TCP/IP settings in AirPort, are you suggesting entering manually under "Configure IPv4" or under "Configure IPv6"? In the current settings, Configure IPv4 is set as "Using DHCP" and Configure IPv6 is set as Automatically. I don't want to mess up anything until I'm sure I'm adjusting the correct settings! Thanks again and Happy New Year!
     
  10. toolbox macrumors 68020

    toolbox

    Joined:
    Oct 6, 2007
    Location:
    Australia (WA)
    #10
    Yes IPV4 don't worry about IPv6

    Make sure IPv4 is set to manual there is where you key in your information
     
  11. testcard thread starter macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England

Share This Page