Network, XP, win7 and OS X....?

Discussion in 'Mac Basics and Help' started by sramota, Dec 25, 2010.

  1. sramota, Dec 25, 2010
    Last edited: Dec 25, 2010

    sramota macrumors newbie

    Joined:
    Dec 25, 2010
    #1
    So,
    I tried Windows forums and help sites... And... No, just no.

    Here's the deal:
    Xmas. At my parents.

    Previously: 2 XP computers and a printer. Worked.

    NOW:
    1 Win 7 laptop. WIFI, can't see anyone else on network.
    Windows firewall on, Avast! installed but off
    Edit: but can ping XP and connect via \\xp\backup to find that folder..

    1 XP, with printer. WIRED to router. Can see but not connect to Win7.
    Windows firewall on, McAfee installed but firewall off
    1 MacBook (2007). WIFI. Can see both windows computers but not connect to either, can also identify printer albeit not make it print.
    No firewall or antivirus (duh)
    Edit: MacBook can now connect to XP. But not print.

    NETGEAR router.
    Canon MP540 printer.

    How the hell do I get these to play nicely together?
     
  2. agentphish macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #2
    It's been my experience, and I may be wrong, but Windows units typically need users to have passwords set in order to connect to them from the Mac.

    If you enable file and print sharing, they should show in the finder left sidebar, or if you click GO > Connect to server and type smb://192.168.1.102 (or whatever your windows box IP is) you'll be prompted to enter a username/password for the unit and you should be able to access whatever you have shared.

    Make sure you share the printer on the XP unit and install the mac driver from the MFR website onto the Mac. You should add the printer via print & fax from system prefs and either do it by IP printer if the printer supports it, or via the Windows tab under add printer.

    Seems like there's some network configuration mishaps going on on the Windows units. Could be something with the assigned workgroup name on each machine. I would just change them to default, which is "workgroup"
     

Share This Page