Networking and Sharing, Help please!

Discussion in 'Mac Basics and Help' started by Wolvngelz, Mar 12, 2008.

  1. Wolvngelz macrumors member

    Joined:
    Dec 24, 2007
    Location:
    Brunei + Melbourne
    #1
    Hey guys,

    I am a new owner of a MBP and I'm currently setting up a Network with my 2 housemates (both PC's).

    I can access the other 2 Computers on my laptop but when one of the 2 PC's try to access my shared folder, it notifies them that Access is Denied, Please contact administrator.

    I've switched on sharing on the laptop but there are a few options there I'm not familiar with, can anyone help?
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Sure. In order to use Windows Sharing you must enable it for each account that you want access granted to, including guest access.
     
  3. Wolvngelz thread starter macrumors member

    Joined:
    Dec 24, 2007
    Location:
    Brunei + Melbourne
    #3
    I'm pretty sure I've done that already, but do you mind elaborating how just to be sure?
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Open System Preferences, then Sharing. Check Windows Sharing if it isn't already checked. Then, click Accounts..., and add each account that you wish to grant Windows Sharing access to by clicking the plus sign then selecting the account from the list.
     
  5. Wolvngelz thread starter macrumors member

    Joined:
    Dec 24, 2007
    Location:
    Brunei + Melbourne
    #5
    There is no "Windows Sharing" but I checked the box "File Sharing" then I added all the users there is on the list (and the PC users aren't on the list...)
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    Yes, this is normal. I'm sorry about the Windows Sharing thing, I was thinking of Tiger, not Leopard. :eek: Anyway... if you want Windows users to connect to your Mac, you either have to make them their own accounts on the Mac, or grant guest access for sharing. If the Guest option doesn't appear, the Guest account may be turned off. To fix this go into Accounts, select the Guest account (after typing your password to unlock it) and enable it.
     
  7. Wolvngelz thread starter macrumors member

    Joined:
    Dec 24, 2007
    Location:
    Brunei + Melbourne
    #7
    Sigh, done all of the above, now the PC's aren't able to "see" the Laptop on their Network List. Any ideas?
     
  8. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #8
    Make sure all computers are in the same Windows workgroup. I'm not sure where Apple hid this setting in Leopard, but I believe it's in System Preferences.
     
  9. Wolvngelz thread starter macrumors member

    Joined:
    Dec 24, 2007
    Location:
    Brunei + Melbourne
    #9
    Yeah all the PC's are in the same Workgrp as is the laptop. It's under System Preferences > Networks > Advanced etc.

    Yet, still nothing. I'll experiemnt more when I wake up later. Thx for your help so far.
     
  10. GirthP macrumors regular

    Joined:
    Oct 1, 2007
    #10
    There is an "Options" button below the drop down list of names you have registered. Make sure SMB is clicked.

    I have done this a few times, so you have accounts set up on your mac with the exact same name and password as you Windows machines? That should be the only problem.
     
  11. Wolvngelz thread starter macrumors member

    Joined:
    Dec 24, 2007
    Location:
    Brunei + Melbourne
    #11
    Now I'm trying to add the PC name to the list of people who have access, but it won't let me. Do I have to configure something on the PC?

    I can still can get files from the PC into the Mac but not the other way around.
     
  12. daizuki8 macrumors newbie

    Joined:
    Mar 13, 2008
    #12
    No idea if this will do the trick or not but I used to have the same problem. I read somewhere that if you have the same username for the computer, then it would work. So I simply renamed my buddies PC to the same name as mine, and after that it worked fine.

    Could be worth a try anyhow!
     

Share This Page