Networking error connecting from PC to Mac but fine the other way around

Discussion in 'Mac OS X Server, Xserve, and Networking' started by dbit, Nov 24, 2014.

  1. dbit, Nov 24, 2014
    Last edited: Nov 24, 2014

    dbit macrumors regular

    Joined:
    May 2, 2006
    #1
    About two weeks after I upgraded my Mac Mini to Yosemite I woke up one morning and kept getting the following prompt's from my PC when connecting to my mini:

    [​IMG]

    I have never had a problem connecting to this mini before. They are members of the same homegroup (workgroup), SMB sharing is turned on for all accounts, the permissions are set correctly and very liberally, I have checked with firewall on and off and performed all necessary tweaks.

    I've tried changing the domain by entering the computer name\account name, the workgroup name\account name, nothing will be accepted. I've checked and rechecked passwords, created new accounts, nothing seems to be working.

    [​IMG]

    [​IMG]

    The mini still connects fine to the PC, but the PC cannot connect to the mini. Both computers still connect fine to my Macbook Pro. I've made sure there are users on the machines with the same account name, I've even created a new account with new credentials and it still won't connect. I've gone into windows administration tools and deleted credentials and built new ones, nothing seems to work.

    As best I can see either the PC is holding onto some corrupted credential information, or the mac has switched something that I cannot find to save my life.

    Does anyone have any suggestions at all?
     
  2. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #2
    No idea, but I jyst discovered I have the same problem.
     
  3. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #3
    OK I just got mine to work
    I Windows & control panel Administrative tools - Local Security policy- Go to "Local Policies > Security Options"
    I used to use "Network Security: LAN Manager Authentication Level".
    In the window that pops up change the setting to "Send LM & NTLM - use NTLMv2 session if negotiated"

    But I changed it to...
    "Send NTLMv2 response only"
     
  4. dbit thread starter macrumors regular

    Joined:
    May 2, 2006
    #4
    Thanks much dimme, I will check this out tomorrow and report back! :)
     
  5. dbit thread starter macrumors regular

    Joined:
    May 2, 2006
    #5
    Thanks for the suggestion dimme, but no dice for me, did not work. I do remember setting that a while back so was hopeful. Any other thoughts?

    Anybody else come across this problem?
     
  6. dbit thread starter macrumors regular

    Joined:
    May 2, 2006
    #6
    Well after a few restarts and flushing the dans cache this seems to have worked!

    Thanks so much dimme for the suggestion! Does anyone have any clue why this might have worked? Was there some issue with a protocol change in yosemite?
     
  7. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #7
    Thank would be my guess. I believe Yosemite used smb3.
     
  8. dbit thread starter macrumors regular

    Joined:
    May 2, 2006
    #8
    Ah I did read it uses 3 and falls back on 2. Didn't know this would affect the NTLMv2 negotiation. Weird that it took weeks for the problem to crop up.

    Anyhow, thanks so much! :D

    d
     

Share This Page