Networking Help

Discussion in 'Mac Basics and Help' started by Zepeleptic, Nov 28, 2010.

  1. Zepeleptic macrumors newbie

    Joined:
    Nov 28, 2010
    #1
    Hello I have been browsing this forum for the last few hours and have not yet found a solution for my problem and would really appreciate some help. I am very new to Macs, I bought a Mini yesterday and am attempting (read: failing) to set up my home network. Here is what I have:

    Netgear WNDR3700 home network with a WPA2 wireless network.

    A Windows 7 (completely updated) desktop with file sharing but not homegroup on. I have even deactivated my windows firewall while attempting to set this up.

    A Mac Mini running OSX 10.4 with Windows Networking activated

    I originally hoped to plug my mac mini in and, while I was quickly able to browse the web, I was less than successful in accessing my shared files that are on my windows 7 machine. I then deactivated the homegroup and simply "shared" the folders via right-clicking and sharing to all users on the network. I am unable to see the mac mini when opening up the network which was the first sign of trouble. I have all of the file sharing options on Windows 7 and Mac Mini checked (network discovery, etc.) but do not have any luck. The farthest success I have reached was I manually entered the ip of my windows 7 pc on the mac mini and while I saw the shared folders, they were empty.

    Note: I do have identical user accounts set up between the two computers, with the same user name and no password.

    I hope I provided enough information, feel free to let me know if you need anything else.

    Thank you so much for any help you could provide! :)
     
  2. mrbash macrumors 6502

    Joined:
    Aug 10, 2008
    #2
    Windows 7 file sharing is problematic. You are not alone in this.

    The first thing you can do is go to finder and select Go->Connect to Server.
    In the dialog, type in:
    smb://<ip_address_of_win7_host>/

    Then it should ask you for a username/password. If successful, you should get a list of shared folders. If not, try first pinging the IP address of the Win7 box:

    Go to Applications/Utilities/Terminal
    This should open a terminal session.
    type:
    ping <ip_address_of_win7_host>

    Also try:
    ping <name_of_win7_host>.local

    Note that you have to put in the ".local" for some reason.
     
  3. Zepeleptic thread starter macrumors newbie

    Joined:
    Nov 28, 2010
    #3
    Thank you for the suggestions, they are much appreciated. I successfully pinged the host as you suggested. I was also able to connect to the Win7 host using connect to server. It listed the shared folders, but when I open them up they contain no files. When I hit "get info" they even give me the correct amount of free and used space, but there are 0 objects. :confused:
     
  4. mrbash macrumors 6502

    Joined:
    Aug 10, 2008
    #4
    Check to see if you can get a listing from the terminal window.

    Type in:

    cd /Volumes/<name of shared_folder>
    ls -l

    If there is a space in the name of the folder, you will have to preceed it with the character "\". That is the backslash character above the "return" key.
     
  5. Zepeleptic thread starter macrumors newbie

    Joined:
    Nov 28, 2010
    #5
    Thanks for the follow-up. It comes back as {IP Address of Host}: Permission Denied, and goes onto list the volumes that are on my mac mini (my local hard drive and my external)

    Is there something I need to do on the Windows 7 end in order to open this up then?
     
  6. Zepeleptic thread starter macrumors newbie

    Joined:
    Nov 28, 2010
    #6
    I have since tried to set up an FTP server to share instead, and even though I am following the instructions perfectly i still get a denial. There must be something wrong with my network connection on the mac end. Any tips and tricks would be really appreciated! :)
     
  7. mrbash macrumors 6502

    Joined:
    Aug 10, 2008
    #7
    I am not sure what problems you are expriencing with your FTP server, but the SMB file share issue is most likely due to incorrect permissions. Your Windows host is rejecting the username/password that you have supplied to access the share.
     

Share This Page