Networking problem (5Ghz and iTunes Home Sharing)

Discussion in 'Mac OS X Server, Xserve, and Networking' started by BulkHedd, Nov 8, 2015.

  1. BulkHedd macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #1
    I have the latest Airport Extreme base station. My main media computer is a Windows 10 desktop wired into the router.

    I find that when I connect my Apple TV to the 5Ghz wifi band the speeds are MUCH faster (tested with the Speedtest app). I don't see any YouTube buffering/resolution changing on 5Ghz but I do on the 2.4Ghz band.

    However, when I connect to the 5Ghz band the Computer app on the ATV says I need to turn on Home Sharing but it is on and iTunes is running.

    If I switch over to the 2.4Ghz band Home Sharing works great. If I switch back to the 5Ghz it doesn't work anymore. This is verified without rebooting or restarting any hardware.

    I do have an older Airport Extreme in my living room that I'm using as a wifi extender. Could that be the problem?
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Depends if you are using the AC network while the older Airport router can only do N signals.
     
  3. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #3
    I'm not sure exactly what you mean. Everything else works fine on the 5Ghz network (YouTube, Netflix, Hulu....). It just doesn't see my iTunes Home Sharing.
     
  4. satcomer, Nov 8, 2015
    Last edited: Nov 19, 2015

    satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    AC is the new wireless "beeming" wireless tech that is different the older N wireless standards. So if your older Airport router that doesn't do AC and only go as high as the N wireless standard.

    So if you connected to the AC wireless you are sharing on then any of you devices on the N wireless will no see the sharing. To see the sharing all you device need to be sharing the same wireless frequencies! Then you should be able to see the sharing.
     
  5. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #5
    The older router is extending the 2.4Ghz band. The 5Ghz band is coming from the newer router, which the Windows PC is directly connected to.
     
  6. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #6
    As a test I used an Ethernet cable and plugged the ATV into the older Airport Extreme (being used as an extender for 2.4GHz band) and it works fine. I can see the Home Shares instantly and streaming is working great.

    If I unplug the Ethernet and switch back to the 5Ghz band I can no longer access my Home Shares. I don't understand this. The 2.4Ghz and 5Ghz bands are both on the same network.
     
  7. Jonny75 macrumors member

    Joined:
    Jun 5, 2008
    Location:
    UK
    #7
    Homeshare is riddled with problems and is barely fit for purpose. The problems aren't even consistent across devices but what you are describing is reasonably well recognised.

    Frequency seems to be crucial to Homeshare as well as SSID, so 2.4GHz and 5GHz bands sharing an SSID makes no difference. The Apple TV will only Homeshare with devices on the same band.

    You can't force your Mac or Apple TV to use a certain wifi band, so your only consistent option is Ethernet or switching off 5GHz (which seems pointless). While this is a solution, Apple TV (including the latest) is stuck on 10/100 ethernet and so Homesharing and Internet speeds max out at 100Mbps, enough for HD though.

    This still doesn't explain why you can have everything on the same band and Apple TV is happy to Homeshare with iTunes but you can't connect your iOS devices, stuck with the half circle of doom.
     
  8. eRondeau macrumors 6502a

    eRondeau

    Joined:
    Mar 3, 2004
    Location:
    Canada's South Coast
    #8
    I've had this happen too. Sign out of Home Sharing on all devices then reboot your Airport Extreme and all your devices. Sign back in while keeping your fingers crossed.
     
  9. IHelpId10t5 macrumors 6502

    Joined:
    Nov 28, 2014
    #9
    This comment is simply not true unless the router is purposely configured to have a separate network for 2.4 vs 5GHz! ANY computers that are connected to the wireless router, regardless of frequency or standard (802.11a, b, g, n, ac) will be on the same network and will be able to see all resources on the subnet.

    Make sure that your router is not purposely configured to create a separate network for each of these bands. Also, if you are using wireless on the Airport Express, but are then plugging into a different router, then you need to make sure that your actual router is providing DHCP, and your AirPort Express and/or extender are set to simply "bridge" the wireless traffic . If you just hook up the AirPort Express to another router then you will have double NATing (bad), and also two different networks. All of your computers need to be on the same local subnet, using the same IP scheme so that zero-config networking (which most of Apple's sharing services use) will work.

    Check the IP addresses of all of the computers that you want to use sharing on. They ALL need to be on one the same non-routable local IP addressing such as 10.0.x.x, or 192.168.x.x. If you see that some are on the 192. subnet, but others are on the 10. subnet, then you need to reconfigure your network.
     
  10. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #10
    @BulkHedd In AirPort Utility, under Wireless --> Wireless Options, do you have "5 GHz Network Name" checked? If so, uncheck it and check if it works then. Unchecking that box will delete the 5 GHz SSID and let the AirPort negotiate the best band to use with each client (2.4 GHz or 5 GHz).
     
  11. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #11
    If I uncheck the 5Ghz doesn't that turn off that band? I prefer that band for my devices. When doing an internet speed test I always get a much higher speed on the 5Ghz band than on the 2.4Ghz band.
     
  12. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #12
    No. It will simply make the 5 GHz and 2.4 GHz networks use the same network name.
     
  13. Jonny75 macrumors member

    Joined:
    Jun 5, 2008
    Location:
    UK
    #13
    @ ihelpid10t5

    I have both frequencies on the same network and the frequency banding is an issue for Homeshare, not for any other device I own.

    If you look at the Apple forums this comes up quite a bit too. You are right it should not make a difference at all, but with Honeshare and whatever secret sauce is going on, it seems to.
     
  14. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #14
    I don't see a box to check. Just a box to type in the name. Do you mean delete the name?
     
  15. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #15
    The tick box right next to 5 GHz network name. [​IMG]
     
  16. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #16
    Also check out your broken network and try the fixes in the article Optimize WiFi Network Stream Music AirPlay. It might help in your situation!
     

Share This Page