Networking Problem

Discussion in 'Mac Pro' started by dpaanlka, Aug 15, 2007.

  1. dpaanlka macrumors 601

    dpaanlka

    Joined:
    Nov 16, 2004
    Location:
    Illinois
    #1
    I have two computers directly connected to my Mac Pro via ethernet, and the Mac Pro share's its wireless internet connection to them. However if I shut the two other computers off for a while and try to turn one back on, it doesn't show up in Network Status, and nothing I do seems to bring it back to life unless I restart the Mac Pro. Both of these other computers (other Macs) do this now, and they did not do this when I first got the Mac Pro.

    What might be going on here?
     
  2. doc james macrumors member

    Joined:
    May 3, 2007
    #2
    Without sounding defeatist, I've never had any joy getting wired and wireless connections working simultaneously on the Mac and the problems it causes are variable. I think you'd be better off getting a wireless hub but there are others here who are MUCH more intelligent than me...
     
  3. SDAVE macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #3
    I've run into similar situations and through the help of this site and various others, I figured out the problem.

    Right now the Mac Pro is running directly to a Windows PC (Server) via Gigabit crossover cable (PC Gigabit card has no autoswitch). The Mac Pro is also running on a wireless connection for internet.

    What you need to do is make sure that your direct connection is NOT set to DHCP and is static....also the subnets matter as well.

    For example, all computers should have an IP such as this:

    Computer 1(Mac Pro):
    IP: 190.168.2.110
    Subnet Mask: 255.255.255.0
    Router/Gateway: NONE (Leave blank)

    Computer 2:
    IP: 190.168.2.111
    Subnet Mask: 255.255.255.0
    Router/Gateway: NONE (Leave blank)

    Computer 3:
    IP: 190.168.2.112
    Subnet Mask: 255.255.255.0
    Router/Gateway: NONE (Leave blank)

    Usually Wireless connections go to the IP 192.168.1.102, so we're trying to stay away from it here.

    Also under OSX, go to the Apple menu up to the top left, then go to Location > Network Preferences and under "Show" pick "Network Port Configurations" and then move the gigabit network wired connection above AirPort.

    Also if you are using Windows, go to Network Connections, then under Advanced > Advanced Settings move your "Local Area Connection" above Wireless. Also "if" you are using Windows, never ever use Network Setup Wizard.

    Hope this helps
     

Share This Page