Networking questions

Discussion in 'Mac Basics and Help' started by ercw, Jul 6, 2006.

  1. ercw macrumors regular

    May 4, 2006
    So I bought a router so both my mac could be hooked to my cable modem.
    I figured out how to configure it works fine. Then I thought it would be cool if both computers could network with each other because my wife and I could exchange files and also use the same printer etc..
    (I'm a long time Mac user but never done a network before)

    In the process of trying to poke around to make this happen, I must have made a huge stupid mistake trying to set new permissions for my hard drive. (which I don't think needed to be done)

    The result: blue screen of death!

    I was able to recover from this by booting in safe mode and assign a new scmod to the lib but I was on the verge of sobing like a little girl.

    two things have changed since this event:

    1)I learned I should ask people who know how to do networking before I do stupid stuff

    2) Because the new router assigned a new IP to my network, I'm unable to
    to recreate the path to my files in the "site folder" that I use for my localhost apache stuff.
    Apache seems to work fine because I can see it when I path it to the ip address but I can't find a path to my local file no mo'!

    Please help a dummie
  2. Palad1 macrumors 6502a


    Feb 24, 2004
    London, UK
    If both machines are running windows, you can just use the other's machine name and netbios will do its magic (bleh!) and transform \\mywifecompy\share to the appropriate address.

    If you have a Mac in there, I don't think you can do netbios name resolution, so you'd better have some sort of name resolution handy.

    If your router can act as a dns server, use your router.
    If your lan is setup with static addresses, edit your c:\windows\system32\drivers\etc\host file and add the following line :
    Code: wifesmac #replace with the correct ip address
    On the mac side, sudo vi /etc/host and add this:
    Code: hubbypc #replace with the pc's ip addess
    If you are using dhcp, you are SOL, unless someone more knowlegeable comes to your rescue :)
  3. Eraserhead macrumors G4


    Nov 3, 2005
    you could try using no-ip ( you can set this up to work so that it tells the server every hour what your IP address is, if you are only using it locally you will need to set that up, it's also free!

    One thing I have noticed with DHCP is that in general you get the same address all the time so it should work ok with DHCP... (in general, unless it's at Uni and you go away for the holiday or something...)

    Alternatively you can switch off DHCP but if someone else want's to join your network you will need to give them a 192.168.x.x address manually.
  4. ercw thread starter macrumors regular

    May 4, 2006
    FYI: both machines are macs and both Ip addresses are different by one digit as they should be. Using DHCP. Each mac is single users.
    We can see eachother machines in the network window, file sharing and printer sharing are on. when trying to log on the other computer, we get denied access.
    (wrong password etc)
  5. Eduter macrumors newbie

    Jul 7, 2006
    How to copy the Profile on a G5?

    How can I copy the user's Profile on a G5?:confused:
  6. Darwin macrumors 65816


    Jun 2, 2003
    round the corner
    When logging on to the other computer are you entering in the Login name and password for your computer?

    You would have to put in the login info for an account on that other machine or if you just wanted to trade a file or two then you could just login as a guest

    Apart from that everything else is in order from the sounds of things

    That is the nature of DHCP (Dynamic Host Configuration Protocol)

    It distributes out IP address for the network, when a machine logs onto the network it talks to the DHCP and is given an IP address, once that machine leaves the network or is shutdown it frees up that IP address and the system then gives that IP address to the next machine to asks
  7. Palad1 macrumors 6502a


    Feb 24, 2004
    London, UK
    Darwin is right on the money.

    Do you have the same accounts setup on both machines?
    What are the contents of the machine's log files?

    Just pop a terminal open on both machines, and type
    tail -f /var/log/system.log
    Then try to connect and watch the changes to the logfile, you may get some insight on what's going on.

    Feel free to post it here so we can help (although weed out the sensitive info that it may contain. urls, names...)

    And sorry about missing the fact that they were both Macs...
  8. ercw thread starter macrumors regular

    May 4, 2006

    Thank you. (au fait: ALLEZ ZIZOU!)
    I'm going to put the networking problem aside for now. My main concern is that I have an "access denied" in my localhost using the new ip and /~myusername (web sharing is on) looks like something changed there. Maybe an Apache config. By the way here is what came up when I did you unix command:

    Last login: Fri Jul 7 15:53:43 on console
    Welcome to Darwin!
    eric:~ eric$ tail -f /var/log/system.log
    Jul 7 15:53:41 localhost kernel: IPv6 packet filtering initialized, default to accept, logging disabled
    Jul 7 15:53:41 localhost kernel: IP firewall loaded
    Jul 7 15:53:41 localhost ConsoleMessage: Starting internet services
    Jul 7 15:53:41 localhost xinetd[302]: 302 {init_services} no services. Exiting...
    Jul 7 15:53:43 localhost TabletDriver[317]: ANSI keyboard: ANSI
    Jul 7 15:54:25 localhost mach_init[2]: Server 0 in bootstrap d03 uid 0: "/usr/libexec/fix_prebinding": exited with non-zero status 1 [pid 350]
    Jul 7 16:00:35 localhost /Applications/ *** Warning: ATSUSetFontFallbacks has been deprecated. Use ATSUFontFallbacks objects instead. ***
    Jul 7 16:26:31 localhost kernel: resize: max chain len 31, new table size 8192
    Jul 7 16:42:04 localhost Fetch 5.0.4 (5A785)[372]: do_quit_close_window (kNavUserActionReviewDocuments) — public_html
    Jul 7 16:42:14 localhost /Applications/ *** Warning: ATSUSetFontFallbacks has been deprecated. Use ATSUFontFallbacks objects instead. ***

    is there anything weird in there you can see?

    (damn I whish I could watch the finals, I work on Sunday)
  9. Palad1 macrumors 6502a


    Feb 24, 2004
    London, UK
    Sounds like you have disk permissions problems.

    if you get an acces denied (HTTP 403.1) error code while reaching http://localhost/~user with personal web sharing enabled (and maybe the firewall as well), here are the causes:
    1. Apache can't read ~/Sites
    2. Apache authentification is turned on and is misconfigured

    Apache's log are located here:
    /var/log/httpd/acces.log # standard log
    /var/log/httpd/error.log  # error log
    Monitor those while accessing your http://localhost/~user share (command-n opens a new terminnal window)

    Did you enable FileVault on your account?
    Is your ~/Site directory world-readable? Just to make sure:
    chmod a+rx ~/Site  #in order to make your site dir world readable
    chmod -R a+r ~/Site/ # let's make some files readable inside this directory
    chmod a+rx ~ # ensure that apache can do a cd ~ even if the files themselves are not readable
    Here is what the permissions should look like:
    Welcome to Darwin!
    florian@bender$ls -lsa
    total 728
      0 drwxr-xr-x   42 florian  florian    1428 Jul  1 16:08 .
      0 drwxrwxr-t    8 root     admin       272 Mar 11 10:26 ..
      0 drwxr-xr-x    6 florian  florian     204 Nov 12  2005 Public
    Or... maybe you could try to repair permissions using the disk utility?

    Good luck!
    on est en finale.. on est en finale... :D
  10. Palad1 macrumors 6502a


    Feb 24, 2004
    London, UK
    ps: you don't have any idea what a a pain it is to type the ~ key on a french Mac. Damn you Apple! Somebody think of the coders! :)
  11. ercw thread starter macrumors regular

    May 4, 2006
    Ok, I tried all the prompts but all I get is this:

    Last login: Sat Jul 8 08:01:54 on ttyp1
    Welcome to Darwin!
    eric:~ eric$ /var/log/httpd/acces.log
    -bash: /var/log/httpd/acces.log: No such file or directory
    eric:~ eric$ /var/log/httpd/error.log
    -bash: /var/log/httpd/error.log: No such file or directory
    eric:~ eric$ /var/log/httpd/acces.log
    -bash: /var/log/httpd/acces.log: No such file or directory
    eric:~ eric$ chmod a+rx ~/Site
    chmod: /Users/eric/Site: No such file or directory
    eric:~ eric$

    should apache be located in the usr/local folder? cause it ain't there, did I lose it?

    Repairing the disk permissions with disk utilities was the first thing I did. I'm pretty sure I tried without the firewall on as well and also made sure I tried without the router plugged in.
    Remember, I think I tweeked something when I was trying to set up the machines for networking like an idiot.
    I think that what screwed things up was when I went macintosh HD/get info and changed the ownership&permissions to me , the user instead of "system" then I "Apply to enclosed items.
    After I did that, my HD icon disapeared from the desktop and when I rebooted I ended up with the blue screen of death.
    I was able to revive it by entering some commands in safe mode I found on the Apple site. Some involved, creating new pref file and single user mode stuff but the one that finally worked was the one that involved a schmod # thingy.

    After the desktop was able to look normal again, I went to disk utilities and repair permissions.

    Obiously I'm good enough to be dangerous but it looks like you got a black belt in computers. Sorry for the long message.

Share This Page