Networking troubles- Ethernet switch woes

Discussion in 'Mac Basics and Help' started by sethypoo, Dec 22, 2010.

  1. sethypoo macrumors 68000

    Joined:
    Oct 8, 2003
    Location:
    Sacramento, CA, USA
    #1
    Hey everybody,

    Before I start, I want to say that I've done extensive searching trying to find a post that covers my issue, but I've had no luck. Netgear's customer support is abysmal to boot, so here I am turning to the awesome Macrumors community!

    Here's the deal: I have a cable modem that I used to have plugged into an Airport Express, that wirelessly connected my Macs, Xbox, iPad, etc. I recently got a blu-ray player that only has a wired connection, so I bought a Netgear Fast Ethernet Switch FS105. I now have my cable modem plugged into port #5, and the Airport, Xbox, and BR player plugged into ports 1, 2, and 3.

    After restarting all the above equipment, I only get Internet via the Airport Express. The Xbox and BR player won't connect despite being plugged unto the switch as well. I have no idea why this is, and I can't find any answers online. Any help you could provide would be great!

    Thank you!
     
  2. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #2
    The way you have it set up it will be a first come first serve. One internet connection at a time. Not all at the same time. You need to have the modem connected to a router(Airport Extreme or other) with ethernet input and ethernet output (LAN and WAN?) then to the switch.
     

Share This Page