Never backed up or jailbroken 3GS 4.0 stuck in recovery; just need the data.

Discussion in 'Jailbreaks and iOS Hacks' started by Islandient, Dec 15, 2011.

  1. Islandient macrumors newbie

    Joined:
    Dec 15, 2011
    #1
    Hi, I'm new to the forum and hoping that someone can help me help a friend. Sorry if this has been asked and answered in another post, but if so I couldn't find it.

    My friend has a 3GS that she has used for a couple years that suddenly went into a recovery mode loop. She has never even connected the phone to a computer, much less updated, backed up, or jailbroken it. It failed while she was on a trip so she got a new iPhone 4 from AT&T, but unfortunately she always used the 3GS as her primary address book, so it is full of business and personal contacts that she reallly needs. I have already chastised her thoroughly for not backing it up and have showed her how to sync the new one.

    The bottom line is that we just need a way to get the contacts - in any format - off the old phone, one time. We don't necessarily care if it ever even works again.

    I am the most tech-savvy person she knows here on the island of St. Croix. My background is PC systems and network administration, with a fair amount of (outdated now) software development experience. I remember enough Unix to make many Linux commands familiar, but my Mac skills are almost nonexistent (I do have access to a Mac if necessary). I have spent a week scouring forums and trying various tools (all on my Windows 7 laptop), so far with no luck. Here is a summary (I apologize in advance if any of it is obvious and/or dumb):

    1. "Hard" reset always returns to recovery mode (picture of USB cable to iTunes) after a few seconds on Apple logo.

    2. RecBoot, iREB, etc. will kick it out of recovery and will also put it into DFU, but it always goes back to recovery mode when restarted.

    3. TinyUmbrella finds it but shows a different ECID (with a question mark) every time it starts, and shows Device Model as “-INVALID”. Save SHSH does nothing (no Saved SHSH listed for device and no files in the save directory.

    4. Redsn0w (0.9.9b8) finds the phone and reports a consistent, properly formatted ECID and build (iPhone2,1_4.0_8A293). It seems to successfully Fetch the blobs and create a file, but says Cydia refused them and Verify throws a warning with the file name followed by “No blobs found”.

    5. iRecovery -s connects, but setting auto-boot to true and saveenv has no effect, and printenv, fsboot, and reboot do not work (I might be doing it wrong?). Here is what I get from iRecovery -s:

    iRecovery - Recovery Utility
    by westbaer
    Thanks to pod2g, tom3q, planetbeing, geohot and posixninja.

    Found iPhone/iPod in Recovery mode
    [NAND] Found Chip ID 0x3E94D72C8400 on FMI0:CE0
    [NAND] Found Chip ID 0x3E94D72C8400 on FMI1:CE8

    =======================================
    ::
    :: iBoot for n88ap, Copyright 2010, Apple Inc.
    ::
    :: BUILD_TAG: iBoot-889.24
    ::
    :: BUILD_STYLE: RELEASE
    ::
    :: USB_SERIAL_NUMBER: CPID:8920 CPRV:15 CPFM:03 SCEP:03 BDID:00 ECID:000002
    417606C32F IBFL:01 SRNM:[8602393JEDG]
    ::
    =======================================

    [FTL:MSG] Apple NAND Driver (AND) RO
    [NAND] Found Chip ID 0x3E94D72C8400 on MI0:CE0
    [NAND] Found Chip ID 0x3E94D72C8400 on FMI1:CE8
    [FTL:MSG] FIL_Init [OK]
    [FTL:MSG] BUF_Init [OK]
    [FTL:MSG] FPart Init [OK]
    read new style signature 0x43313133 (line:405)
    [FTL:MSG] VSVFL Register [OK]
    [FTL:MSG] VFL Init [OK]
    [FTL:MSG] VFL_Open [OK]
    [FTL:MSG] YAFTL Register [OK]
    [FTL:MSG] FTL_Open [OK]
    Boot Failure Count: 0 Panic Fail Count: 1
    Entering recovery mode, starting command prompt
    dialog_read_adc timeot, MUX_SEL=2
    limiting USB input current to 100 mA
    ]​

    6. I downloaded iPhone2,1_4.0_8A293.ipsw and used a tool called make_noerase_ipsw to generate an upgrade file, then did Shift+Click Restore in iTunes. This gets past "verifying" and "preparing" and all the way to the point where the phone is at the logo screen with the progress bar, but fails with error 6 after a few seconds. I have tried all of the online suggestions for fixing error 6, but none of them make any difference. I have considered trying this process with the newest build (5.0.1?) but have not done that yet.

    I would be happy to do a jailbreak if that would work. I have also begun looking at the ramdisk process, but have not tackled it yet in hopes that there is an easier solution.

    My friend owns a dive shop and I'm sure we could arrange some free diving for anyone who can bail us out (and get to St. Croix)!
     
  2. Selena Gomez macrumors member

    Joined:
    Dec 15, 2011
    #2
  3. Islandient thread starter macrumors newbie

    Joined:
    Dec 15, 2011
    #3
    Thanks for the quick reply! Here is where I am now:

    1. Run fixrecovery in command window.
    2. Place phone in DFU.
    3. Get this in command window:
    Initializing libpois0n
    ERROR: The process "iTunes.exe" not found.
    ERROR: The process "iTunesHelper.exe" not found.
    Checking the device type
    Preparing to upload limera1n exploit
    Resetting device counters
    Sending chunk headers
    Sending exploit payload
    Sending fake data
    Exploit sent
    Reconnecting to device
    Waiting 2 seconds for the device to pop up...
    Preparing to upload iBSS
    Checking if iBSS.n88ap already exists
    Preparing to fetch DFU image from Apple's servers
    Fetching Firmware/dfu/iBSS.n88ap.RELEASE.dfu...
    Uploading iBSS.n88ap to device
    Reconnecting to device
    Waiting 10 seconds for the device to pop up...
    Preparing to upload iBSS payload
    Loaded payload for iBSS on n88ap
    Resetting device counters
    Uploading iBSS payload
    Executing iBSS payload
    Initializing greenpois0n in iBSS
    Checking if device is already jailbroken
    Exiting libpois0n

    Now phone shows:
    =============================================
    greenpois0n
    http://www.greenpois0n.com
    =============================================
    Unable to find gBdevList
    Unable to find fs_mount
    Unable to find fs_unmount
    Unable to find fs_load_file
    Greenpois0n initialized

    and is just sitting there.

    This looks promising, but I really don't know what I'm supposed to do next. Don't mean to be an idiot, but need a little more guidance.

    The diving is for real (on a great boat on the second longest barrier reef in the Caribbean) if we can get this fixed!

    Thanks again!
     
  4. Selena Gomez macrumors member

    Joined:
    Dec 15, 2011
    #4
    Seen this error plenty of times before. Make sure you're not using a third party USB 30-pin connector. iTunes should be installed on your machine. Use a different Windows machine.

    Using a different Windows machines has solved countless problems in the past.
     
  5. Islandient thread starter macrumors newbie

    Joined:
    Dec 15, 2011
    #5
    OK, I have now tried this on all USB ports on 2 different PC's with three different cables (all Apple originals): same exact result.

    Could it have anything to do with the fact that the versions you sent are 421 and 43, but the phone is running 4.0?

    I really appreciate your help, and the diving awaits!
     
  6. Selena Gomez macrumors member

    Joined:
    Dec 15, 2011
    #6
    Run the tool with iTunes open in the background. Be sure Apple Mobile Support (I'm not at my computer, so I think that's the process name in Task Manager) is running while you do this. If this doesn't work, bear with me. There's never been an iPhone error I couldn't fix.
     
  7. Islandient thread starter macrumors newbie

    Joined:
    Dec 15, 2011
    #7
    Well, having iTunes running made no difference (and the first thing that the app did was to kill iTunes). If you mean the Apple Mobile Device , I checked and it was running. I restarted it anyway, but the result was the same.

    I'm glad to hear you haven't let an iPhone beat you yet, and thanks for hanging in there on this one. I really hope we can get it!
     

Share This Page