Never ending popup!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iTimmaH, Sep 16, 2009.

  1. iTimmaH macrumors newbie

    Joined:
    Sep 16, 2009
    #1
    iPhone 3G 16GB, about a year old.

    So I got a speaker dock for the phone and when you first plug it in it says "This accessory is not made to work with iPhone Would you like to turn on Airplane Mode to reduce audio inteference? You will not be able to make or recieve phone calls". This is fine. I hit no and theres no problem...

    One sunny day two months later, this same message decideds to pop up without being plugged into the dock. I hit no and no more than 30 seconds later it pops up again... and again and again!!! So I think okay it must WANT to be in Airplane Mode so I hit yes and it ignores me, stays connected to the network and the message pops up again and again and again!

    I've tried updating to 3.1 (I wasn't seeing as many messages), restoring and updating (no good) and spanking the phone and telling it to stop misbehaving (this was purely for my own benefit).

    Has anyone else come across this problem? Or overcome it? Any suggestions? Please dont tell me its a hardware problem and I have to send it to apple....PLEEEEEASE!!
     
  2. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #2
    Check the dock connector on the bottom of the phone to make sure the contacts are clean. A tiny bit of dust could be bridging the contacts and causing it to thing that there is a dock attached to it.

    Alternatively I'd continue to spank it and see how far you get with that.
    Out of interest, do the messages stop if you manually put it into airplane mode?
     
  3. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #3
    Thats odd. The big thing is making sure the contacts in the dock connector are clean like what has been mentioned. The next option would be go to apple?
     

Share This Page