never sleep

Discussion in 'OS X Yosemite (10.10)' started by zoran, Jul 7, 2016.

  1. zoran macrumors 68030

    Joined:
    Jun 30, 2005
    #1
    How can my iΜac be never put to sleep? I want to connect from a remote Mac to my iMac using team viewer but due to the fact that the iMac sleeps I cannot make the connection.
     
  2. RootBeerMan macrumors 6502

    RootBeerMan

    Joined:
    Jan 3, 2016
    #2
    Go to System Preferences> Energy Saver and set the computer to Never sleep. That's how I've always done it.
     
  3. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #3
    Τhanx, although this is an easy way to keep the computer active, it is not the best way to do so. I wish i could configure my computer to wake up on LAN, but it does seem so hard for me to set it that way! Might there be a simple way to do the WAKEonLAN configuration?
     
  4. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #4
    I've always done like RootBeerMan mentioned. I have my monitors turn off but the computer stays on.
     
  5. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
  6. Toutou macrumors 6502a

    Toutou

    Joined:
    Jan 6, 2015
    Location:
    Prague, Czech Republic
  7. RootBeerMan macrumors 6502

    RootBeerMan

    Joined:
    Jan 3, 2016
    #7
    I have my iMac (which I'm typing this on) set to never sleep. It seems to work for me. In the same panel in the preferences is an option to wake for ethernet (LAN) access. Just check it. (Unless it's changed significantly from my older OSX version).
     
  8. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #8
    Yes, but you can set the display to go off after an amount of time and then check to prevent computer from sleeping automatically when the display is off. There should also be another option for Wake for network access.
     
  9. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #9
    Im using WakeOnLan app and have entered all the needed settings (iPv4 and MacAdress) but still the computer im tryingto wake will not wake.
    What else can i do?
     
  10. Tech198 macrumors G4

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #10
    I have the same issue with my Mac Mini using screen sharing.. (Finder sidebar) with back to my Mac..

    Desktop goes to sleep and it won't wake up from BTTM

    Got on the phone to Apple. They informed me the reason why it doesn't wake is third party routers don't always support Bonjour fully in all cases... which i am using a Billion 700NL with my Mac's

    This would make sense, so i guess an Airport extreme, or Express would solve the problem.. I haven't got either so i can't test this out..

    Only way i can think of doing this, is not let your computer sleep at all.
     

Share This Page