New 13" Macbook Pro - sound issue

Discussion in 'macOS' started by jrap, Jun 10, 2009.

  1. jrap macrumors newbie

    Joined:
    Mar 9, 2008
    #1
    Hi all, I have an interesting problem if anyone can lend a hand.

    I had a first gen aluminum 13" Macbook that I spilled beer on. It was basically a write-off, but fortunately the HD was not damaged.

    I just got my 13" Macbook Pro today, and replaced the new HD with my old one. Everything is working fine, except that there is no sound.

    When I go to System->Sound I see "No Output devices found", and when I press the sound buttons on the keyboard, the speaker is grayed out.

    I know this is not a Hardware issue for a couple reasons. First, it properly 'chimes' on startup. Second, I did try running the computer with the new hard drive, and during the sound was working properly, volume adjustment buttons working, etc.

    Also, in System Profiler, the build-in sound is recognized.

    What I have done so far: Reset PRAM/NVRAM, used Disk Utility to Repair Disk Permissions, used onyx to delete any caches.

    Nothing has worked yet.

    So this has to be a driver issue related to Leopard. Is there a way I can re-install the sound drivers? Or go reinstall Leopard without losing any of my data?

    Many thanks!


    edit: I was going to place this in the Macbook Pro forum, but since this appears to be a software issue I posted here. Sorry if it's the wrong location.
     
  2. iShater macrumors 604

    iShater

    Joined:
    Aug 13, 2002
    Location:
    Chicagoland
    #2
    So using the original installation with the new machine? I would imagine since the hardware is slightly different, a reinstall of the OS is probably necessary.

    Edit: reinstalling the OS will not erase your data, but before doing any work ALWAYS backup.
     
  3. billmac123 macrumors newbie

    Joined:
    Jun 11, 2009
    #3
    Same problem

    I have exactly the same problem with my new Macbook Pro (incidentally, I also had to write off my old water-spilled MacBook...). Called Applecare today and tried all kind tricks. No luck. I am going to try reinstalling. But before I do that, want to see anyone had any luck with other method.
     
  4. aintnohalfstppn macrumors newbie

    Joined:
    May 3, 2005
    #4
    same thing here. I bought it last night, spent 3+ hours doing a restore from my time machine backup and then no sound.
    i'm going to the apple store within the next hour, so hopefully something good will come of it.
     
  5. jrap thread starter macrumors newbie

    Joined:
    Mar 9, 2008
    #5
    Reinstalling Leopard did work for me, my sound is back.

    Since you are reinstalling the same version of leopard, you have to use the following trick

    This worked perfectly for me.

    I also had to run disk utilities and repair disk after installation, there was a miscount in the number of directories or something?
     
  6. aintnohalfstppn macrumors newbie

    Joined:
    May 3, 2005
    #6
    so, they gave me a new one and after another 3 hour time machine restore, there was still no sound. i reinstalled the os and boom...sound.
     
  7. jrap thread starter macrumors newbie

    Joined:
    Mar 9, 2008
  8. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #8
    Sure Optical wasn't on by mistake? It can be a rare glitch, and using a paper clip or putting in headphones can help get the analogue/optical switch to.. switch.
     
  9. rkrskr macrumors newbie

    Joined:
    Oct 18, 2008
    #9
    Hi,

    I'm facing this issue too. Like you, I put my 320 GB HDD from my MacBook unibody into the new MacBook Pro 13", and there is no sound available.

    I'll be doing a clean install of Mac OS X, and use migration assistant with Time Machine to restore all my programs. I had initially thought of doing an Archive and Install, but the thought of having extra data on my HDD did not go down well with me.
     
  10. drew0020 macrumors 65816

    drew0020

    Joined:
    Nov 10, 2006
    #10
    Same problem here. I restored from a time machine backup. I hear the startup chime, but then get no sound with my SSD. The sound works perfectly with the standard HD.

    Guess this is going back to Apple plus I think ill wait it out till they get the SATA II thing figured out.
     
  11. drew0020 macrumors 65816

    drew0020

    Joined:
    Nov 10, 2006
    #11
    How long does migration assistant with time machine take?
     
  12. captainmo macrumors newbie

    Joined:
    Jun 22, 2009
    #12
    I have the same problem as everyone else here but unfortunately I have lost my install disk. I have one from the earlier Macbook 13 inch, but the sound doesn't work after a clean install.

    I would LOVE it if someone could upload the following kexts from a New MacBook PRO 13 inch located in /System/Library/Extensions/

    Apple02Audio.kext
    AppleFWAudio.kext
    AppleHDA.kext
    AppleOnboardAudio.kext
    AppleUSBAudio.kext
    AudioDeviceTreeUpdater.kext
    AudioIPCDriver.kext
    IOAudioFamily.kext
    SM56KUSBAudioFamily.kext
    VirtualAudioDriver.kext
     
  13. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #13
    @ captainmo: I zipped a folder of the kext files and published it to my iDisk public folder. Note that I'm running 10.5.7
     
  14. captainmo macrumors newbie

    Joined:
    Jun 22, 2009
    #14
    Thank you so much! This solved my problem right away after installing the kexts with Kext Helper [http://cheetha.net/]
     
  15. blassox macrumors newbie

    Joined:
    Jun 24, 2009
    #15
    I can't solve it! Can anyone help me to install kext? I've tried as captainmo said, but after reboot still no sound device... I've a new macbook pro 13 and I've reinstalled osx, migrated from a time machine backup with assistant and everything worked fine, but after a reboot: NO SOUND
    Thanks.
     
  16. sashok macrumors newbie

    Joined:
    Sep 17, 2007
    #16
    Really?

    I wasn't as fortunate to have such good luck. I installed the kexts - all at one time - and rebooted. Sound icon still grayed out and not present in the menu bar. It chimes on start-up just fine.

    My original scenario is similar to that of the original poster (jrap). Had an aluminum 13" MacBook. Upgraded to 13" MacBook Pro. Swapped hard drives.

    For me, however, the sound system preferences pane crashes when I click on it.

    Question: did you install all the kexts at once or one at a time?
     
  17. mrsltazvivinga macrumors newbie

    Joined:
    Oct 2, 2010
    #17
    above kexts crushed leopard 10.5.8

    well i installed the above kexts from the idisk,and guess wat my macbookpro5.1 crushed,yeah,it did,used the kexthelper as suggested,but as it turned it couldnt boot no more it only gave the normal booom start up sound then nothing other than white screen,i were running 10.5.8 on macbookpro5.1 (15inch) all i wanted is to fix sound and those kexts crushed maybe coz of wrong model or os version,dont know exactly just thought to warn others,ryt now am temporarily using ubuntu till i get snow leopard,how can i boot it from usb ???
     

Share This Page