New 15" MBP Blue Flashing Screen...

Discussion in 'MacBook Pro' started by andruw000, Mar 29, 2011.

  1. andruw000, Mar 29, 2011
    Last edited: Mar 29, 2011

    andruw000 macrumors newbie

    Joined:
    Nov 7, 2010
    #1
    Purchased a BTO 15" 2.0 8GB 128 SSD MBP about three weeks ago. Everything had been running flawlessly until last night.

    I ran Onyx for the first time on it and during the maintenance, my screen started to flash/blink to a blue screen for about 1/2 a second. This went on until the process finished in about 20 second intervals. I wasn't sure what the problem was but after a restart it stopped.

    Then, about three hours later, after exiting out of starcraft, my screen started doing the same thing. The blinks/flashes seemed to get more intense/bright this time. Again, I restarted and the issue subsided. I tried to look up the problem but couldn't find anyone else that had this issue. I have not plugged it into an external display, nor have I messed with the Thunderbolt port.

    Any idea what this problem might be? I really don't want to have to send it in and wait weeks on end, but it might be my only option.
     
  2. Naimfan macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
    #2
    Try a clean install and see if that fixes it. Otherwise, it sounds like you'll have to send it in.

    You might also try uninstalling Onyx before a clean install, since the problem seemed to start after you installed it.
     
  3. andruw000 thread starter macrumors newbie

    Joined:
    Nov 7, 2010
    #3
    Update...

    I've now noticed that my screen will flicker only directly after playing Starcraft. Therefore, I believe the issue is related to the discrete graphics card. Whenever I restart, the issue subsides and I believe this is because the system automatically switches back to the integrated graphics.

    Could my discrete graphics card be causing flickering on my display? Does this make sense?
     

Share This Page