New 2012 Mini Server Mystery Restart

Discussion in 'Mac mini' started by DFWHD, Mar 20, 2015.

  1. DFWHD macrumors regular

    Joined:
    Aug 6, 2011
    #1
    I've got a one month old 2012 Mini server purchased new that is running the latest version of Yosemite 10.10.2 that is rebooting on its own every few days. When this happens, it boots to the recovery menu. The only upgrade I've done is replacing the delivered 4GB ram with 8GB of Crucial ram which was ordered from Crucial and is the correct spec for this model. When this happens, the last message in the console prior to the restart is not consistent, but a couple of times has been "Attempt to use XPC with a MachService that has HideUntilCheckIn set. This will result in unpredictable behavior: com.apple.smbd". Google searches have led me to believe this is not the issue.

    Here is some more information:
    • The server is running headless using a CompuLab HDMI Display Emulator (allows 1920 x 1080 resolution on remote access)
    • The server is not accessible from the internet
    • In Sharing, I have file sharing, printer sharing, remote login and remote management set
    • In Power Settings the server is set not to sleep. Sharing settings also would prevent sleep from what I understand.
    • I have two USB 3 drives attached to the Mini, one to backup the server to and another to backup my other Macs via the network.
    • The server is running the latest server.app which is where I established the time machine folder for the other macs for backup

    If anyone can offer any advise on how to track down the cause I'd greately appreciate it
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Have you tried swapping the ram back?

    Is there something specific being done on another machine when the reboot occurs?
     
  3. jmbaker macrumors newbie

    Joined:
    Nov 20, 2014
    #3
  4. DFWHD thread starter macrumors regular

    Joined:
    Aug 6, 2011
    #4
    Thanks for the quick response. I've not swapped ram yet, but will do that tonight after work. None of the other machines were backing up when the issue has occurred.

    Thanks for the quick response. It's plugged into a UPS and there have been no power failures. The logout after setting is not enabled. I don't think it could be the spotlight corruption issue as it always boots to the recovery mode when this happens. Wouldn't that reboot back to the normal login screen?
     
  5. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #5
    Agree with above poster who advised you to re-install the OLD RAM.

    I suggest you do this and run it for at least one week with the original RAM installed.

    Do you get any restarts during this time frame?

    If the answer is no, put the new RAM in for another week.

    Any restarts?

    If so, the problem should become obvious...
     
  6. jmbaker macrumors newbie

    Joined:
    Nov 20, 2014
    #6
    Testing the RAM is a good idea. Besides just swapping it, try testing the module you have installed:

    http://guides.macrumors.com/Testing_RAM

    Basically, start in single user mode, then at the command prompt type "memtest all"

    While you're there, may as well run fsck to check the filesystem for errors.
     
  7. DFWHD thread starter macrumors regular

    Joined:
    Aug 6, 2011
    #7
    Update - Still restarting

    So on Friday night I swapped the Crucial ram for the stock apple ram so the server is as it was when I purchased it and set the Mini on course. Sunday morning the issue arose again. At that time I ran the Apple Server Diagnostics (ran close to 24 hours) and all tests passed. Now we're here on Tuesday night and found the issue again when I got home from work just now. At this point I'm at a loss. I really had high hopes for this setup. I guess it's time to call Apple and see what the geniuses can do. I'm guessing first they''ll have me wipe the hard drive and reinstall OS X... Oh Joy...
     
  8. scottyy macrumors member

    Joined:
    Mar 24, 2015
    #8
    Sounds like it could be a psu problem.

    Hopefully Apple can get it solved quickly.
     

Share This Page