New 2013 MBA can't install windows 8, partition error

Discussion in 'Windows, Linux & Others on the Mac' started by jasonj566, Jun 19, 2013.

  1. jasonj566 macrumors member

    Joined:
    Jun 19, 2013
    #1
    I've spent hours trying to research this. I'm able to download support drivers and then try to install windows 8 pro via a usb dvd drive. I get to the point of picking the partition from windows and format it like always done in the past with other computers with no problems, after i format the bootcamp partition it doesn't allow me to go past that by hitting the next button. it comes up with an error "windows cannot be installed to this disk. the selected disk is of the GPT partition style"....frustrating, any help out there?
    Jason
     
  2. cu2cool macrumors newbie

    Joined:
    Sep 23, 2012
    #2
    I had the same problem and spent days trying to figure it out. This was the only guide that actually allowed me to bypass that GPT error message.

    http://www.tech-recipes.com/rx/9839/how-to-manually-partition-boot-camp-your-mac-for-windows-7/

    Even after I was finally able to get Windows 8 to finally install, the Bootcamp 5 drivers will still not install properly on our MBAir (mid 2013) models. You won't be able to run the setup.exe. It will give an error message:

    To work around that you will need to follow this guide, http://www.iphoting.com/blog/archives/830-Boot-Camp-on-Older-Intel-based-Macs.html

    After all the drivers have been installed, you still won't be able to use anything properly (no right-click, scroll, brightness settings, network, etc.) So essentially, it's useless.

    This other forum post describes somebody else's problems getting usb mouse and keyboard to work, but the last response agrees with the notion that new drivers haven't been included in the Bootcamp 5 installer to support the new chipset in the mid 2013 MBA models.

    I've also tried contacting Apple support via online chat and they had no solutions for me.

    Our best bet is probably to wait until the next release/update of Bootcamp for Mac.
     
  3. KPOM macrumors G5

    Joined:
    Oct 23, 2010
    #3
    On the MacBook Air forum someone posted that it appears the 2013 models now support EFI boot. Maybe give it a shot.
    http://forums.macrumors.com/showthread.php?t=1600147
     
  4. Livewings macrumors regular

    Joined:
    Dec 16, 2012
    #4
    Bootcamp for MBA 2013 only works in EFI mode.
    Make sure when you boot into Windows Setup created by Boot Camp,
    you boot into the EFI_BOOT partition, not the WININSTALL partition.

    It will allow you to proceed and install bootcamp drivers as per normal.

    With EFI mode, you get 3 second bootups, faster shutdowns, faster wakeups etc.
     
  5. cu2cool macrumors newbie

    Joined:
    Sep 23, 2012
    #5
    I did install in EFI mode, but I am still getting the same error. When trying to run setup.exe from the Bootcamp 5 extracted folder.

    After you install Windows 8 via USB, and remove the USB drive, can you still see the EFI mode in the boot options? I cannot.
     
  6. Livewings macrumors regular

    Joined:
    Dec 16, 2012
    #6
    It's supposed to be that way but it still boots in EFI mode.

    The only way you can tell whether its booting in BIOS mode or EFI Mode is that...
    After you press Enter on your Windows 8 partition, it shows the Windows logo INSTANTLY.
    BIOS Mode will have the blinking underscore in the top left before showing the Windows logo a few seconds later.

    Make sure you download the support software from Bootcamp itself.
    If you downloaded from Apple website, you did it wrong.
    The support software from there is dated from March.
    You need to go back to Mac OS and download the support software using Bootcap.
     
  7. cu2cool macrumors newbie

    Joined:
    Sep 23, 2012
    #7
    You sir, are a genius. I downloaded bootcamp drivers through bootcamp assistant about a week before the release of the mid 2013 MBA. I didn't think anything new was available, also because nothing new was on the Apple website.

    Downloaded the new drivers with the bootcamp assistant (Version 5.0.5241) and now I am a happy camper. :)
     
  8. torana355 macrumors 68020

    Joined:
    Dec 8, 2009
    Location:
    Sydney, Australia
    #8
    All you have to do is restart the mac and it will work.
     
  9. jasonj566 thread starter macrumors member

    Joined:
    Jun 19, 2013
    #9
    all fixed

    i just copied my windows 8 dvd disk to a usb 2.0 drive and then downloaded drivers for bootcamp on same usb disk, then started install and worked perfectly
     
  10. miksuad macrumors newbie

    Joined:
    Jun 24, 2013
    #10
    I had the exact same problem with the 2013 MBA. The solution was to allow the Boot Camp Assistant to create the bootable USB stick from the Windows 8 ISO. I first tried to install the Win8 from an USB stick which I had used to install it on my PC and that caused the GPT partition problem.

    So, here's what I did:

    1. Downloaded the Windows 8 ISO from MSDN on my Mac.
    2. Launched Boot Camp Assistant
    3. Made sure that all the 3 options were checked
    4. Allowed Boot Camp to do its stuff
    5. After the reboot, Win 8 installation started automatically. Only thing I had to do was to format the Bootcamp-partition from the Win 8 installation wizard.

    Only problem now is that the built-in keyboard & trackpack doesn't work...
     
  11. Whosjohnny macrumors newbie

    Joined:
    Sep 23, 2013
    #11
    Finally got mine to work

    I wasn't sure if I want to go into the trouble of subscribing and registering just to respond to this but I figure this might help.

    For some apparent reason, my .ISO file was able to be recognized by boot camp 5 as it is picky as heck, rejecting many versions of windows not being 64 bit or whatever.

    After finally passing boot camp 5 and install drivers on external USB device, after reboot, nothing, keep booting back into Mac OS. Hold down Options, see EFI choose that and USB flashes (high-speed 45MBPS SD card in a reader hub, saw somewhere that it may be a problem) so at first I thought its the problem with my USB SD. I almost gave up and I decided since I have one of those old fashion external DVD enclosures and hook it as another USB Device and physically burn it into a bootable DVD, that worked!!

    Since no one mentions this, I thought I share for whatever reason, bootcamp 5 didn't want to install using hard drive version of the ISO.

    After install Windows 8 Pro, it keeps crashing after a minute or so and I read a lot of people having same problem. Disable Wifi from network devices (right click using two-finger-touch AND click over Wifi network device) and use LAN was the last I read on the web and that Apple do not officially support Windows 8 but that may changed recently. I haven't done a lot of research into this yet.

    Again, luckily I have a USB 2 to Gigabit RJ45 adapter for my MacBook Air 2013 does not have one built in. Afterwards, no more crashes.

    I even install Lineage II on it as Lineage II infamously for 9 years can only be dreamt to run on a Mac, now I can natively play multiple Lineage 2 windows on external thunderbolt to HDMI to DVI adapter for my Dell Ultra 1920x1200 24" screen smooth as butter on my 11.6" body. Granted, I always use ultra portable USB powered travel style large fan blowing across the side to prevent overheating during high load PC gaming.

    Another thing, Bootcamp thread running in just installed Windows 8 Pro takes up 25-33% of the entire CPU on idle causing severe battery drain or heating, I read everywhere there is no fix. I just ctrl-alt-del and kill the process. Since I thought everything is installed, I can just kill it no need for it. So far, CPU idle down to ultra efficient 0-1% in win 8 pro after boot camp, runs stable without boot camp thread in windows. Watch your CPU usage on idle if you're suspicious.

    HTH.

    John
     
  12. Michael Goff macrumors G3

    Michael Goff

    Joined:
    Jul 5, 2012
    #12
    Doesn't work at all?

    Or doesn't work the way you expected? Because it worked wonky for me (2012, not 2013) until I put the drivers on there.
     
  13. Whosjohnny macrumors newbie

    Joined:
    Sep 23, 2013
    #13
    update: wifi crash and bootcamp high cpu usage

    Hi again,

    I had a chance to play with the Windows 8 Pro a bit more on this newly installed machine MacBook Air 11.6" 2013 model.

    After the initial bootcamp 33% high cpu usage during idle, after I kill the process and reboot, the high cpu usage never came back. I thought the bootcamp process no longer loads but last I checked, it's running @ 0% cpu idle usage - so that's great.

    Wifi crashing after initial Windows 8 Pro install is a common problem reported by many. I disabled it, installed USB to GigLan external adapter and play some games over that RJ45, I unplug USB to RJ45 adapter... turn on Wifi, so far no crashes.

    The wifi is a funny thing, sometimes when you enable it in Windows 8 Pro, it doesn't seem to see any wifi network. I have tried reboot, sure that works but I found a faster way. Point to top-right of Window 8 pro, Settings, Power, Sleep. 1-2 seconds, later, hit any key and log back in, Wifi works again. It may be the "sleep" mode to conserve power driver isn't working perfectly - I don't know.
     
  14. goldfiction macrumors newbie

    Joined:
    Nov 15, 2013
    #14
    How I solved this problem

    Hi, I had same problem as everyone in this post.
    I have been here several times before and after a lot of trying, I resolved my problems.

    1. Make sure you have windows 8.1. It is different from windows 8.0. windows 8.1 will allow install to formatted partition running in EFI mode while 8.0 won't.

    2. If you have issue with EFI boot, you can repartition and install without EFI. But this is very bad idea. I installed windows 8.0 without too much trouble first time without EFI boot option. Windows will not recognize network card, will not recognize nvidia driver. It is pretty much toast if you want to play anything 3D. What I mean is that you must install in EFI mode.
    To tell if you are in EFI mode in mac pro, just see if the screen is very large and the fonts are really really tiny. Somehow the EFI will load a lot of mac drivers to windows installation process. And all the drivers will recognize after you boot to windows 8.1.
    When you start up, press option key before any thing shows up on screen. Then you can choose from 5 drives: mac, help, local windows, usb windows, usb windows efi. If you choose local windows, it goes to local partition and might fail if you haven't installed windows. USB windows will install windows without EFI, don't touch this one. USB windows with EFI is the one you want to use to install windows 8.1. After first reboot, you can unplug the usb drive and always choose local windows. It will be loading EFI through bootcamp if you installed it right.

    3. Don't use sdcard plus USB reader for making the installation disk. Especially my sdcard are class 4, it pretty much took 4 hours without unstucking itself and I gave up. Use a normal usb pen drive.

    4. Windows 8.1 will install a lot of apps after the first reboot and it takes up to half an hour. That is normal, be patient for this.

    5. I forgot to mention, if you install windows to bootcamp partition, you won't be able to click next button. People say format it. I did with windows 8.0, but after the install complete, in the last step, I get unable to alter boot record. I solved by using windows 8.1 instead.

    6. windows 8.1 has different activation tools than 8.0... You need to find a different one.
     

Share This Page